ML-DSA Signature Verification Accepts Signatures with Repeated Hint Indices
CVE-2026-24850GHSA-5x2r-hc65-25f9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ml-dsa 0.1.0-rc.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io ml-dsa
- Affected
- >= 0.0.4, < 0.1.0-rc.4
- Fixed in
- 0.1.0-rc.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5x2r-hc65-25f9 lists affected ranges: crates.io ml-dsa >=0.0.4 <0.1.0-rc.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
- EPSS
- CVE-2026-24850: 0.34% estimated exploitation activity in the next 30 days; percentile 26.91 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Affected Crate: ml-dsa Affected Versions: v0.1.0-rc.2 (and commits since b01c3b7) Severity: Medium Reporter: Oren Yomtov (Fireblocks) Summary The ML-DSA signature verification implementation in the RustCrypto ml-dsa crate incorrectly accepts signatures with repeated (duplicate) hint indices. According to the ML-DSA specification (FIPS 204 / RFC 9881), hint indices within each polynomial must be strictly increasing. The current implementation uses a non-strict monotonic check (<= instead of <), allowing duplicate indices. Note: This is a regression bug. The original implementation was correct, but commit b01c3b7 ("Make ML-DSA signature decoding follow the spec (#895)", fixing issue #894) inadvertently changed the strict < comparison to <=, introducing the vulnerability. Vulnerability Details Root Cause The vulnerability is located in the monotonic helper function in ml-dsa/src/hint.rs: The comparison operator <= allows equal consecutive values, meaning duplicate hint indices are not…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-5x2r-hc65-25f9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-24850 Advisory: ML-DSA Signature Verification Accepts Signatures with Repeated Hint Indices IDs: CVE-2026-24850, GHSA-5x2r-hc65-25f9 Record: https://patchnext.com/advisories/cve-2026-24850 (revision 1, source checked 26 Oct 2026, 15:39 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ml-dsa 0.1.0-rc.4. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io ml-dsa: affected >= 0.0.4, < 0.1.0-rc.4; fixed in 0.1.0-rc.4 ## Suggested inspection (read-only) - crates.io ml-dsa: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ml-dsa. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-5x2r-hc65-25f9 (GitHub-reviewed advisory GHSA-5x2r-hc65-25f9 lists affected ranges: crates.io ml-dsa >=0.0.4 <0.1.0-rc.4) Commands are suggestions: review each one before running it.
Loading voting…