Skip to content

← Actionable
Medium, CVSS 6.5

malcontent OCI image pull credential exfiltration via malicious registry token realm

CVE-2026-24845GHSA-9m43-p3cx-w8j5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/chainguard-dev/malcontent 1.20.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N
EPSS
  • CVE-2026-24845: 0.38% estimated exploitation activity in the next 30 days; percentile 31.51 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Malcontent could be made to expose Docker registry credentials if it scanned a specially crafted OCI image reference. Malcontent uses google/go-containerregistry for OCI image pulls, which by default uses the Docker credential keychain. A malicious registry could return a WWW-Authenticate header redirecting token authentication to an attacker-controlled endpoint, causing credentials to be sent to that endpoint. Fix: Default to anonymous auth for OCI pulls Acknowledgements Thank you to Oleh Konko from 1seal for discovering and reporting this issue.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-9m43-p3cx-w8j5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-24845

Advisory: malcontent OCI image pull credential exfiltration via malicious registry token realm
IDs: CVE-2026-24845, GHSA-9m43-p3cx-w8j5
Record: https://patchnext.com/advisories/cve-2026-24845 (revision 1, source checked 26 Oct 2026, 15:14 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/chainguard-dev/malcontent 1.20.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/chainguard-dev/malcontent: affected >= 0.10.0, < 1.20.3; fixed in 1.20.3

## Suggested inspection (read-only)
- Go github.com/chainguard-dev/malcontent: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/chainguard-dev/malcontent.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-9m43-p3cx-w8j5 (GitHub-reviewed advisory GHSA-9m43-p3cx-w8j5 lists affected ranges: Go github.com/chainguard-dev/malcontent >=0.10.0 <1.20.3)

Commands are suggestions: review each one before running it.

Loading voting…