melange pipeline working-directory could allow command injection
CVE-2026-24844GHSA-vqqr-rmpc-hhg2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (chainguard.dev/melange 0.40.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 0.3.0, < 0.40.3
- Fixed in
- 0.40.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vqqr-rmpc-hhg2 lists affected ranges: Go chainguard.dev/melange >=0.3.0 <0.40.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.9 · CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N
- EPSS
- CVE-2026-24844: 0.20% estimated exploitation activity in the next 30 days; percentile 9.63 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
An attacker who can provide build input values, but not modify pipeline definitions, could execute arbitrary shell commands if the pipeline uses ${{vars.}} or ${{inputs.}} substitutions in working-directory. The field is embedded into shell scripts without proper quote escaping. Fix: Fixed with e51ca30c, Released. Acknowledgements melange thanks Oleh Konko from 1seal for discovering and reporting this issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-vqqr-rmpc-hhg2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-24844 Advisory: melange pipeline working-directory could allow command injection IDs: CVE-2026-24844, GHSA-vqqr-rmpc-hhg2 Record: https://patchnext.com/advisories/cve-2026-24844 (revision 1, source checked 26 Oct 2026, 15:14 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: chainguard.dev/melange 0.40.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Go chainguard.dev/melange: affected >= 0.3.0, < 0.40.3; fixed in 0.40.3 ## Suggested inspection (read-only) - Go chainguard.dev/melange: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on chainguard.dev/melange. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-vqqr-rmpc-hhg2 (GitHub-reviewed advisory GHSA-vqqr-rmpc-hhg2 lists affected ranges: Go chainguard.dev/melange >=0.3.0 <0.40.3) Commands are suggestions: review each one before running it.
Loading voting…