DotNetNuke.Core has a potential XSS vulnerability in modules' header and footer
CVE-2026-24784GHSA-jjwg-4948-6wxp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (dotnetnuke.core 10.2.0, 9.13.10), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
NuGet dotnetnuke.core
- Affected
- >= 9.0.0, < 9.13.10>= 10.0.0, < 10.2.0
- Fixed in
- 9.13.10, 10.2.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jjwg-4948-6wxp lists affected ranges: NuGet dotnetnuke.core >=9.0.0 =10.0.0 <10.2.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.9 · CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:L/A:N
- EPSS
- CVE-2026-24784: 0.19% estimated exploitation activity in the next 30 days; percentile 9.24 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A content editor could inject scripts in module headers/footers that would run for other users.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-jjwg-4948-6wxp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-24784 Advisory: DotNetNuke.Core has a potential XSS vulnerability in modules' header and footer IDs: CVE-2026-24784, GHSA-jjwg-4948-6wxp Record: https://patchnext.com/advisories/cve-2026-24784 (revision 1, source checked 26 Oct 2026, 17:04 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: dotnetnuke.core 10.2.0, 9.13.10. A vendor fix does not mean a deployment is fixed. ## Affected components - NuGet dotnetnuke.core: affected >= 9.0.0, < 9.13.10; >= 10.0.0, < 10.2.0; fixed in 9.13.10, 10.2.0 ## Suggested inspection (read-only) - NuGet dotnetnuke.core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on dotnetnuke.core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-jjwg-4948-6wxp (GitHub-reviewed advisory GHSA-jjwg-4948-6wxp lists affected ranges: NuGet dotnetnuke.core >=9.0.0 =10.0.0 <10.2.0) Commands are suggestions: review each one before running it.
Loading voting…