vLLM vulnerable to Server-Side Request Forgery (SSRF) through MediaConnector
CVE-2026-24779GHSA-qh4c-xf7m-gxfc
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (vllm 0.14.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI vllm
- Affected
- < 0.14.1
- Fixed in
- 0.14.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-qh4c-xf7m-gxfc lists affected ranges: PyPI vllm >=0 <0.14.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qh4c-xf7m-gxfc lists affected ranges: PyPI vllm >=0 <0.14.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:L
- EPSS
- CVE-2026-24779: 0.58% estimated exploitation activity in the next 30 days; percentile 47.71 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A Server-Side Request Forgery (SSRF) vulnerability exists in the MediaConnector class within the vLLM project's multimodal feature set. The loadfromurl and loadfromurlasync methods obtain and process media from URLs provided by users, using different Python parsing libraries when restricting the target host. These two parsing libraries have different interpretations of backslashes, which allows the host name restriction to be bypassed. This allows an attacker to coerce the vLLM server into making arbitrary requests to internal network resources. This vulnerability is particularly critical in containerized environments like llm-d, where a compromised vLLM pod could be used to scan the internal network, interact with other pods, and potentially cause Denial of Service or access sensitive data. For example, an attacker could make the vLLM pod send malicious requests to an internal llm-d management endpoint, leading to system instability by falsely reporting metrics like the KV…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-qh4c-xf7m-gxfc
- Revision 1 · created ·
Published from osv record GHSA-qh4c-xf7m-gxfc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-24779 Advisory: vLLM vulnerable to Server-Side Request Forgery (SSRF) through MediaConnector IDs: CVE-2026-24779, GHSA-qh4c-xf7m-gxfc Record: https://patchnext.com/advisories/cve-2026-24779 (revision 2, source checked 26 Oct 2026, 13:49 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: vllm 0.14.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI vllm: affected < 0.14.1; fixed in 0.14.1 ## Suggested inspection (read-only) - `python -m pip show vllm`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on vllm. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-qh4c-xf7m-gxfc (OSV record GHSA-qh4c-xf7m-gxfc lists affected ranges: PyPI vllm >=0 <0.14.1 (fixed)) - Verified: https://github.com/advisories/GHSA-qh4c-xf7m-gxfc (GitHub-reviewed advisory GHSA-qh4c-xf7m-gxfc lists affected ranges: PyPI vllm >=0 <0.14.1) Commands are suggestions: review each one before running it.
Loading voting…