Ghost vulnerable to XSS via malicious Portal preview links
CVE-2026-24778GHSA-gv6q-2m97-882h
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@tryghost/portal 2.57.1, 2.51.5; ghost 6.15.0, 5.121.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @tryghost/portal
- Affected
- >= 2.29.1, < 2.51.5>= 2.52.0, < 2.57.1
- Fixed in
- 2.51.5, 2.57.1
npm ghost
- Affected
- >= 5.43.0, < 5.121.0>= 6.0.0, < 6.15.0
- Fixed in
- 5.121.0, 6.15.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-gv6q-2m97-882h lists affected ranges: npm ghost >=5.43.0 =6.0.0 =2.29.1 =2.52.0 <2.57.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-gv6q-2m97-882h lists affected ranges: npm ghost >=5.43.0 =6.0.0 =2.29.1 =2.52.0 <2.57.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-24778: 0.29% estimated exploitation activity in the next 30 days; percentile 21.30 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact An attacker was able to craft a malicious link that, when accessed by an authenticated staff user or member, would execute JavaScript with the victim's permissions, potentially leading to account takeover. Vulnerable versions This vulnerability is present in Ghost versions: - v5.43.0 to v5.120.4 - v6.0.0 to v6.14.0 As well as in Portal versions: - v2.29.1 to v2.51.4 - v2.52.0 to v2.57.0 Patches Ghost automatically loads the latest patch of the members Portal component via CDN. Therefore: - For Ghost 5.x users, upgrading to v5.121.0 or later fixes the vulnerability (loads Portal v2.51.5, which contains the patch) - For Ghost 6.x users, upgrading to v6.15.0 or later fixes the vulnerability (loads Portal v2.57.1, which contains the patch) For Ghost installations using a customised or self-hosted version of Portal, it will be necessary to manually rebuild from or update to the latest patch version. References Ghost thanks Younes Belalia for discovering and disclosing this…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-gv6q-2m97-882h
- Revision 1 · created ·
Published from osv record GHSA-gv6q-2m97-882h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-24778 Advisory: Ghost vulnerable to XSS via malicious Portal preview links IDs: CVE-2026-24778, GHSA-gv6q-2m97-882h Record: https://patchnext.com/advisories/cve-2026-24778 (revision 2, source checked 26 Oct 2026, 12:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @tryghost/portal 2.57.1, 2.51.5; ghost 6.15.0, 5.121.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @tryghost/portal: affected >= 2.29.1, < 2.51.5; >= 2.52.0, < 2.57.1; fixed in 2.51.5, 2.57.1 - npm ghost: affected >= 5.43.0, < 5.121.0; >= 6.0.0, < 6.15.0; fixed in 5.121.0, 6.15.0 ## Suggested inspection (read-only) - `npm ls @tryghost/portal --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls ghost --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @tryghost/portal, ghost. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-gv6q-2m97-882h (OSV record GHSA-gv6q-2m97-882h lists affected ranges: npm ghost >=5.43.0 =6.0.0 =2.29.1 =2.52.0 <2.57.1 (fixed)) - Verified: https://github.com/advisories/GHSA-gv6q-2m97-882h (GitHub-reviewed advisory GHSA-gv6q-2m97-882h lists affected ranges: npm ghost >=5.43.0 =6.0.0 =2.29.1 =2.52.0 <2.57.1) Commands are suggestions: review each one before running it.
Loading voting…