Skip to content

← Actionable
Medium, CVSS 4.7amended

Hono vulnerable to XSS through ErrorBoundary component

CVE-2026-24771GHSA-9r54-q6cx-xmh5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (hono 4.11.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm hono

    Affected
    < 4.11.7
    Fixed in
    4.11.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2026-24771: 0.37% estimated exploitation activity in the next 30 days; percentile 31.38 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A Cross-Site Scripting (XSS) vulnerability exists in the ErrorBoundary component of the hono/jsx library. Under certain usage patterns, untrusted user-controlled strings may be rendered as raw HTML, allowing arbitrary script execution in the victim's browser. Details The issue is in the ErrorBoundary component (src/jsx/components.ts). ErrorBoundary previously forced certain rendered output paths to be treated as raw HTML, bypassing the library's default escaping behavior. This could result in unescaped rendering when developers pass user-controlled strings directly as children, or when fallbackRender returns user-controlled strings (for example, reflecting error messages that contain attacker input). This vulnerability is only exploitable when an application renders untrusted user input within ErrorBoundary without appropriate escaping or sanitization. Impact Successful exploitation may allow attackers to execute arbitrary JavaScript in the victim’s browser (reflected XSS).…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-9r54-q6cx-xmh5

  2. Revision 1 · created ·

    Published from osv record GHSA-9r54-q6cx-xmh5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-24771

Advisory: Hono vulnerable to XSS through ErrorBoundary component
IDs: CVE-2026-24771, GHSA-9r54-q6cx-xmh5
Record: https://patchnext.com/advisories/cve-2026-24771 (revision 2, source checked 26 Oct 2026, 12:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: hono 4.11.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm hono: affected < 4.11.7; fixed in 4.11.7

## Suggested inspection (read-only)
- `npm ls hono --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on hono.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-9r54-q6cx-xmh5 (OSV record GHSA-9r54-q6cx-xmh5 lists affected ranges: npm hono >=0 <4.11.7 (fixed))
- Verified: https://github.com/advisories/GHSA-9r54-q6cx-xmh5 (GitHub-reviewed advisory GHSA-9r54-q6cx-xmh5 lists affected ranges: npm hono >=0 <4.11.7)

Commands are suggestions: review each one before running it.

Loading voting…