NocoDB Vulnerable to Stored Cross-Site Scripting via SVG upload
CVE-2026-24769GHSA-q5c6-h22r-qpwr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (nocodb 0.301.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm nocodb
- Affected
- < 0.301.0
- Fixed in
- 0.301.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-q5c6-h22r-qpwr lists affected ranges: npm nocodb >=0 <0.301.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q5c6-h22r-qpwr lists affected ranges: npm nocodb >=0 <0.301.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.5 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H/E:P · score source
- EPSS
- CVE-2026-24769: 0.43% estimated exploitation activity in the next 30 days; percentile 37.67 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A stored Cross-site Scripting (XSS) vulnerability exists in NocoDB’s attachment handling mechanism. Authenticated users can upload malicious SVG files containing embedded JavaScript, which are later rendered inline and executed in the browsers of other users who view the attachment. Because the malicious payload is stored server-side and executed under the application’s origin, successful exploitation can lead to account compromise, data exfiltration and unauthorized actions performed on behalf of affected users. --- Vulnerability Details NocoDB allows file attachments to be previewed inline based on their MIME type. Due to overly permissive MIME type checks and a lack of content sanitization, SVG files containing executable JavaScript are incorrectly treated as safe image content and rendered directly in the browser. Root Cause The vulnerability results from a combination of overly permissive MIME type classification and unsafe file serving behavior. 1. Permissive MIME Type…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-q5c6-h22r-qpwr
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-q5c6-h22r-qpwr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-24769 Advisory: NocoDB Vulnerable to Stored Cross-Site Scripting via SVG upload IDs: CVE-2026-24769, GHSA-q5c6-h22r-qpwr Record: https://patchnext.com/advisories/cve-2026-24769 (revision 3, source checked 26 Oct 2026, 12:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: nocodb 0.301.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm nocodb: affected < 0.301.0; fixed in 0.301.0 ## Suggested inspection (read-only) - `npm ls nocodb --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on nocodb. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-q5c6-h22r-qpwr (OSV record GHSA-q5c6-h22r-qpwr lists affected ranges: npm nocodb >=0 <0.301.0 (fixed)) - Verified: https://github.com/advisories/GHSA-q5c6-h22r-qpwr (GitHub-reviewed advisory GHSA-q5c6-h22r-qpwr lists affected ranges: npm nocodb >=0 <0.301.0) Commands are suggestions: review each one before running it.
Loading voting…