Skip to content

← Actionable
High, CVSS 7.8

PHPUnit Vulnerable to Unsafe Deserialization in PHPT Code Coverage Handling

CVE-2026-24765GHSA-vvj3-c3rp-c85p

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (phpunit/phpunit 12.5.8, 11.5.50, 10.5.62, 9.6.33, 8.5.52), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist phpunit/phpunit

    Affected
    < 8.5.52>= 9.0.0, < 9.6.33>= 10.0.0, < 10.5.62>= 11.0.0, < 11.5.50>= 12.0.0, < 12.5.8
    Fixed in
    10.5.62, 12.5.8, 11.5.50, 8.5.52, 9.6.33

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.8 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-24765: 0.38% estimated exploitation activity in the next 30 days; percentile 32.55 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Overview A vulnerability has been discovered involving unsafe deserialization of code coverage data in PHPT test execution. The vulnerability exists in the cleanupForCoverage() method, which deserializes code coverage files without validation, potentially allowing remote code execution if malicious .coverage files are present prior to the execution of the PHPT test. Technical Details Affected Component: PHPT test runner, method cleanupForCoverage() Affected Versions: <= 8.5.51, <= 9.6.32, <= 10.5.61, <= 11.5.49, <= 12.5.7 Vulnerable Code Pattern The vulnerability occurs when a .coverage file, which should not exist before test execution, is deserialized without the allowedclasses parameter restriction. An attacker with local file write access can place a malicious serialized object with a wakeup() method into the file system, leading to arbitrary code execution during test runs with code coverage instrumentation enabled. Attack Prerequisites and Constraints This vulnerability…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-vvj3-c3rp-c85p

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-24765

Advisory: PHPUnit Vulnerable to Unsafe Deserialization in PHPT Code Coverage Handling
IDs: CVE-2026-24765, GHSA-vvj3-c3rp-c85p
Record: https://patchnext.com/advisories/cve-2026-24765 (revision 1, source checked 26 Oct 2026, 14:39 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: phpunit/phpunit 12.5.8, 11.5.50, 10.5.62, 9.6.33, 8.5.52. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist phpunit/phpunit: affected < 8.5.52; >= 9.0.0, < 9.6.33; >= 10.0.0, < 10.5.62; >= 11.0.0, < 11.5.50; >= 12.0.0, < 12.5.8; fixed in 10.5.62, 12.5.8, 11.5.50, 8.5.52, 9.6.33

## Suggested inspection (read-only)
- Packagist phpunit/phpunit: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on phpunit/phpunit.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-vvj3-c3rp-c85p (GitHub-reviewed advisory GHSA-vvj3-c3rp-c85p lists affected ranges: Packagist phpunit/phpunit >=0 =9.0.0 =10.0.0 =11.0.0 =12.0.0 <12.5.8)

Commands are suggestions: review each one before running it.

Loading voting…