PyTorch Vulnerable to Remote Code Execution via Untrusted Checkpoint Files
CVE-2026-24747GHSA-63cw-57p8-fm3p
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (torch 2.10.0; pytorch 2.10.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-63cw-57p8-fm3p lists affected ranges: PyPI pytorch >=0 <2.10.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record PYSEC-2026-2286 lists affected ranges: PyPI torch >=0 <2.10.0 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-63cw-57p8-fm3p lists affected ranges: PyPI pytorch >=0 <2.10.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-63cw-57p8-fm3p lists affected ranges: PyPI torch >=0 <2.10.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-63cw-57p8-fm3p lists affected ranges: PyPI torch >=0 <2.10.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-24747: 0.80% estimated exploitation activity in the next 30 days; percentile 56.59 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A vulnerability in PyTorch's `weights_only` unpickler allows an attacker to craft a malicious checkpoint file (`.pth`) that, when loaded with `torch.load(..., weights_only=True)`, can corrupt memory and potentially lead to arbitrary code execution.
Vulnerability Details The `weights_only=True` unpickler failed to properly validate pickle opcodes and storage metadata, allowing: 1. Heap memory corruption via `SETITEM`/`SETITEMS` opcodes applied to non-dictionary types 2. Storage size mismatch between declared element count and actual data in the archive
Impact An attacker who can convince a user to load a malicious checkpoint file may achieve arbitrary code execution in the context of the victim's process.
Credit Ji'an Zhou
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 5 · amended ·
Amended from osv record GHSA-63cw-57p8-fm3p
- Revision 4 · amended ·
Amended from ghsa record GHSA-63cw-57p8-fm3p
- Revision 3 · amended ·
Amended from ghsa record GHSA-63cw-57p8-fm3p
- Revision 2 · amended ·
Amended from osv record PYSEC-2026-2286
- Revision 1 · created ·
Published from osv record GHSA-63cw-57p8-fm3p
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-24747 Advisory: PyTorch Vulnerable to Remote Code Execution via Untrusted Checkpoint Files IDs: CVE-2026-24747, GHSA-63cw-57p8-fm3p Record: https://patchnext.com/advisories/cve-2026-24747 (revision 5, source checked 4 Nov 2026, 06:20 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: torch 2.10.0; pytorch 2.10.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI torch: affected < 2.10.0; fixed in 2.10.0 - PyPI pytorch: affected < 2.10.0; fixed in 2.10.0 ## Suggested inspection (read-only) - `python -m pip show torch`: prints the installed version. Run with the environment that serves production active. - `python -m pip show pytorch`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on torch, pytorch. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-63cw-57p8-fm3p (OSV record GHSA-63cw-57p8-fm3p lists affected ranges: PyPI pytorch >=0 <2.10.0 (fixed)) - Verified: https://osv.dev/vulnerability/PYSEC-2026-2286 (OSV record PYSEC-2026-2286 lists affected ranges: PyPI torch >=0 <2.10.0 (fixed)) - Verified: https://github.com/advisories/GHSA-63cw-57p8-fm3p (GitHub-reviewed advisory GHSA-63cw-57p8-fm3p lists affected ranges: PyPI pytorch >=0 <2.10.0) - Verified: https://github.com/advisories/GHSA-63cw-57p8-fm3p (GitHub-reviewed advisory GHSA-63cw-57p8-fm3p lists affected ranges: PyPI torch >=0 <2.10.0) - Verified: https://osv.dev/vulnerability/GHSA-63cw-57p8-fm3p (OSV record GHSA-63cw-57p8-fm3p lists affected ranges: PyPI torch >=0 <2.10.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…