Symfony's incorrect argument escaping under MSYS2/Git Bash can lead to destructive file operations on Windows
CVE-2026-24739GHSA-r39x-jcww-82v6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (symfony/symfony 8.0.5, 7.4.5, 7.3.11, 6.4.33, 5.4.51; symfony/process 8.0.5, 7.4.5, 7.3.11, 6.4.33, 5.4.51), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist symfony/symfony
- Affected
- < 5.4.51>= 6.4, < 6.4.33>= 7.3, < 7.3.11>= 7.4, < 7.4.5>= 8.0, < 8.0.5
- Fixed in
- 7.4.5, 6.4.33, 7.3.11, 8.0.5, 5.4.51
Packagist symfony/process
- Affected
- < 5.4.51>= 6.4, < 6.4.33>= 7.3, < 7.3.11>= 7.4, < 7.4.5>= 8.0, < 8.0.5
- Fixed in
- 7.4.5, 6.4.33, 7.3.11, 8.0.5, 5.4.51
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-r39x-jcww-82v6 lists affected ranges: Packagist symfony/process >=0 =6.4 =7.3 =7.4 =8.0 =0 =6.4 =7.3 =7.4 =8.0 <8.0.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.3 · CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:N/I:H/A:H
- EPSS
- CVE-2026-24739: 0.23% estimated exploitation activity in the next 30 days; percentile 14.03 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The Symfony Process component did not correctly treat some characters (notably =) as “special” when escaping arguments on Windows. When PHP is executed from an MSYS2-based environment (e.g. Git Bash) and Symfony Process spawns native Windows executables, MSYS2’s argument/path conversion can mishandle unquoted arguments containing these characters. This can cause the spawned process to receive corrupted/truncated arguments compared to what Symfony intended. Impact If an application (or tooling such as Composer scripts) uses Symfony Process to invoke file-management commands (e.g. rmdir, del, etc.) with a path argument containing =, the MSYS2 conversion layer may alter the argument at runtime. In affected setups this can result in operations being performed on an unintended path, up to and including deletion of the contents of a broader directory or drive. The issue is particularly relevant when untrusted input can influence process arguments (directly or indirectly, e.g. via…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-r39x-jcww-82v6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-24739 Advisory: Symfony's incorrect argument escaping under MSYS2/Git Bash can lead to destructive file operations on Windows IDs: CVE-2026-24739, GHSA-r39x-jcww-82v6 Record: https://patchnext.com/advisories/cve-2026-24739 (revision 1, source checked 26 Oct 2026, 14:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: symfony/symfony 8.0.5, 7.4.5, 7.3.11, 6.4.33, 5.4.51; symfony/process 8.0.5, 7.4.5, 7.3.11, 6.4.33, 5.4.51. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist symfony/symfony: affected < 5.4.51; >= 6.4, < 6.4.33; >= 7.3, < 7.3.11; >= 7.4, < 7.4.5; >= 8.0, < 8.0.5; fixed in 7.4.5, 6.4.33, 7.3.11, 8.0.5, 5.4.51 - Packagist symfony/process: affected < 5.4.51; >= 6.4, < 6.4.33; >= 7.3, < 7.3.11; >= 7.4, < 7.4.5; >= 8.0, < 8.0.5; fixed in 7.4.5, 6.4.33, 7.3.11, 8.0.5, 5.4.51 ## Suggested inspection (read-only) - Packagist symfony/symfony: check the installed version with your package manager. - Packagist symfony/process: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on symfony/symfony, symfony/process. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-r39x-jcww-82v6 (GitHub-reviewed advisory GHSA-r39x-jcww-82v6 lists affected ranges: Packagist symfony/process >=0 =6.4 =7.3 =7.4 =8.0 =0 =6.4 =7.3 =7.4 =8.0 <8.0.5) Commands are suggestions: review each one before running it.
Loading voting…