Skip to content

← Actionable
Medium, CVSS 5.9

gmrtd ReadFile Vulnerable to Denial of Service via Excessive TLV Length Values

CVE-2026-24738GHSA-j49h-6577-5xwq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/gmrtd/gmrtd 0.17.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.9 · CVSS:4.0/AV:A/AC:L/AT:P/PR:N/UI:P/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-24738: 0.28% estimated exploitation activity in the next 30 days; percentile 20.69 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Unbounded TLV length in ReadFile can cause Denial of Service Summary A Denial of Service vulnerability was identified in ReadFile() where unbounded TLV length values could lead to excessive CPU and memory usage when processing data from a malicious or non-compliant NFC source. This issue has been fixed by enforcing strict limits on acceptable TLV lengths. Affected Versions - Affected: All versions prior to v0.17.2 - Fixed in: v0.17.2 Details ReadFile() processes BER-TLV encoded data returned from an NFC or APDU source via a Transceiver interface. Prior to the fix, the implementation did not enforce an upper bound on long-form TLV length values. A malicious or non-compliant NFC endpoint could advertise an excessively large length (up to 4 GB), causing the library to: - Perform a very large number of read iterations - Allocate excessive memory - Consume significant CPU resources - Block execution for an extended period While such lengths are unrealistic for compliant MRTD or ISO 7816…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-j49h-6577-5xwq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-24738

Advisory: gmrtd ReadFile Vulnerable to Denial of Service via Excessive TLV Length Values
IDs: CVE-2026-24738, GHSA-j49h-6577-5xwq
Record: https://patchnext.com/advisories/cve-2026-24738 (revision 1, source checked 26 Oct 2026, 15:14 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/gmrtd/gmrtd 0.17.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/gmrtd/gmrtd: affected < 0.17.2; fixed in 0.17.2

## Suggested inspection (read-only)
- Go github.com/gmrtd/gmrtd: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/gmrtd/gmrtd.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-j49h-6577-5xwq (GitHub-reviewed advisory GHSA-j49h-6577-5xwq lists affected ranges: Go github.com/gmrtd/gmrtd >=0 <0.17.2)

Commands are suggestions: review each one before running it.

Loading voting…