Apache Tomcat has an Improper Input Validation vulnerability
CVE-2026-24734GHSA-mgp5-rv84-w37q
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.tomcat:tomcat-coyote-ffm 11.0.18, 10.1.52, 9.0.115; org.apache.tomcat:tomcat-coyote 11.0.18, 10.1.52, 9.0.115; org.apache.tomcat.embed:tomcat-embed-core 11.0.18, 10.1.52, 9.0.115), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.tomcat:tomcat-coyote-ffm
- Affected
- >= 11.0.0-M1, < 11.0.18>= 10.1.0-M7, < 10.1.52>= 9.0.83, < 9.0.115
- Fixed in
- 10.1.52, 11.0.18, 9.0.115
Maven org.apache.tomcat:tomcat-coyote
- Affected
- >= 11.0.0-M1, < 11.0.18>= 10.1.0-M7, < 10.1.52>= 9.0.83, < 9.0.115
- Fixed in
- 10.1.52, 11.0.18, 9.0.115
Maven org.apache.tomcat.embed:tomcat-embed-core
- Affected
- >= 11.0.0-M1, < 11.0.18>= 10.1.0-M7, < 10.1.52>= 9.0.83, < 9.0.115
- Fixed in
- 10.1.52, 11.0.18, 9.0.115
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mgp5-rv84-w37q lists affected ranges: Maven org.apache.tomcat:tomcat-coyote >=11.0.0-M1 =10.1.0-M7 =9.0.83 =11.0.0-M1 =10.1.0-M7 =9.0.83 <9.0.115
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mgp5-rv84-w37q lists affected ranges: Maven org.apache.tomcat:tomcat-coyote >=11.0.0-M1 =10.1.0-M7 =9.0.83 =11.0.0-M1 =10.1.0-M7 =9.0.83 =11.0.0-M1 =10.1.0-M7 =9.0.83 <9.0.115
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-mgp5-rv84-w37q lists affected ranges: Maven org.apache.tomcat:tomcat-coyote >=11.0.0-M1 =10.1.0-M7 =9.0.83 =11.0.0-M1 =10.1.0-M7 =9.0.83 =11.0.0-M1 =10.1.0-M7 =9.0.83 <9.0.115 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2026-24734: 0.57% estimated exploitation activity in the next 30 days; percentile 47.50 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Improper Input Validation vulnerability in Apache Tomcat Native, Apache Tomcat. When using an OCSP responder, Tomcat Native (and Tomcat's FFM port of the Tomcat Native code) did not complete verification or freshness checks on the OCSP response which could allow certificate revocation to be bypassed. This issue affects Apache Tomcat Native: from 1.3.0 through 1.3.4, from 2.0.0 through 2.0.11; Apache Tomcat: from 11.0.0-M1 through 11.0.17, from 10.1.0-M7 through 10.1.51, from 9.0.83 through 9.0.114. The following versions were EOL at the time the CVE was created but are known to be affected: from 1.1.23 through 1.1.34, from 1.2.0 through 1.2.39. Older EOL versions are not affected. Apache Tomcat Native users are recommended to upgrade to versions 1.3.5 or later or 2.0.12 or later, which fix the issue. Apache Tomcat users are recommended to upgrade to versions 11.0.18 or later, 10.1.52 or later or 9.0.115 or later which fix the issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from osv record GHSA-mgp5-rv84-w37q
- Revision 2 · amended ·
Amended from ghsa record GHSA-mgp5-rv84-w37q
- Revision 1 · created ·
Published from ghsa record GHSA-mgp5-rv84-w37q
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-24734 Advisory: Apache Tomcat has an Improper Input Validation vulnerability IDs: CVE-2026-24734, GHSA-mgp5-rv84-w37q Record: https://patchnext.com/advisories/cve-2026-24734 (revision 3, source checked 4 Nov 2026, 06:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.tomcat:tomcat-coyote-ffm 11.0.18, 10.1.52, 9.0.115; org.apache.tomcat:tomcat-coyote 11.0.18, 10.1.52, 9.0.115; org.apache.tomcat.embed:tomcat-embed-core 11.0.18, 10.1.52, 9.0.115. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.tomcat:tomcat-coyote-ffm: affected >= 11.0.0-M1, < 11.0.18; >= 10.1.0-M7, < 10.1.52; >= 9.0.83, < 9.0.115; fixed in 10.1.52, 11.0.18, 9.0.115 - Maven org.apache.tomcat:tomcat-coyote: affected >= 11.0.0-M1, < 11.0.18; >= 10.1.0-M7, < 10.1.52; >= 9.0.83, < 9.0.115; fixed in 10.1.52, 11.0.18, 9.0.115 - Maven org.apache.tomcat.embed:tomcat-embed-core: affected >= 11.0.0-M1, < 11.0.18; >= 10.1.0-M7, < 10.1.52; >= 9.0.83, < 9.0.115; fixed in 10.1.52, 11.0.18, 9.0.115 ## Suggested inspection (read-only) - Maven org.apache.tomcat:tomcat-coyote-ffm: check the installed version with your package manager. - Maven org.apache.tomcat:tomcat-coyote: check the installed version with your package manager. - Maven org.apache.tomcat.embed:tomcat-embed-core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.tomcat:tomcat-coyote-ffm, org.apache.tomcat:tomcat-coyote, org.apache.tomcat.embed:tomcat-embed-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-mgp5-rv84-w37q (GitHub-reviewed advisory GHSA-mgp5-rv84-w37q lists affected ranges: Maven org.apache.tomcat:tomcat-coyote >=11.0.0-M1 =10.1.0-M7 =9.0.83 =11.0.0-M1 =10.1.0-M7 =9.0.83 <9.0.115) - Verified: https://github.com/advisories/GHSA-mgp5-rv84-w37q (GitHub-reviewed advisory GHSA-mgp5-rv84-w37q lists affected ranges: Maven org.apache.tomcat:tomcat-coyote >=11.0.0-M1 =10.1.0-M7 =9.0.83 =11.0.0-M1 =10.1.0-M7 =9.0.83 =11.0.0-M1 =10.1.0-M7 =9.0.83 <9.0.115) - Verified: https://osv.dev/vulnerability/GHSA-mgp5-rv84-w37q (OSV record GHSA-mgp5-rv84-w37q lists affected ranges: Maven org.apache.tomcat:tomcat-coyote >=11.0.0-M1 =10.1.0-M7 =9.0.83 =11.0.0-M1 =10.1.0-M7 =9.0.83 =11.0.0-M1 =10.1.0-M7 =9.0.83 <9.0.115 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…