Mattermost Boards Plugin fails to implement authorisation checks on comment block modifications
CVE-2026-2461GHSA-hf8w-x9h5-5gf9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/mattermost/mattermost-plugin-boards 0.0.0-20260108044135-57c5be5b6ef5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/mattermost/mattermost-plugin-boards
- Affected
- < 0.0.0-20260108044135-57c5be5b6ef5
- Fixed in
- 0.0.0-20260108044135-57c5be5b6ef5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hf8w-x9h5-5gf9 lists affected ranges: Go github.com/mattermost/mattermost-plugin-boards >=0 <0.0.0-20260108044135-57c5be5b6ef5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
- EPSS
- CVE-2026-2461: 0.17% estimated exploitation activity in the next 30 days; percentile 6.26 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Mattermost Plugins versions <=11.3 11.0.3 11.2.2 10.10.11.0 fail to implement authorisation checks on comment block modifications, which allows an authorised attacker with editor permission to modify comments created by other board members. Mattermost Advisory ID: MMSA-2025-00559
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-hf8w-x9h5-5gf9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-2461 Advisory: Mattermost Boards Plugin fails to implement authorisation checks on comment block modifications IDs: CVE-2026-2461, GHSA-hf8w-x9h5-5gf9 Record: https://patchnext.com/advisories/cve-2026-2461 (revision 1, source checked 26 Oct 2026, 15:18 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/mattermost/mattermost-plugin-boards 0.0.0-20260108044135-57c5be5b6ef5. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/mattermost/mattermost-plugin-boards: affected < 0.0.0-20260108044135-57c5be5b6ef5; fixed in 0.0.0-20260108044135-57c5be5b6ef5 ## Suggested inspection (read-only) - Go github.com/mattermost/mattermost-plugin-boards: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/mattermost/mattermost-plugin-boards. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-hf8w-x9h5-5gf9 (GitHub-reviewed advisory GHSA-hf8w-x9h5-5gf9 lists affected ranges: Go github.com/mattermost/mattermost-plugin-boards >=0 <0.0.0-20260108044135-57c5be5b6ef5) Commands are suggestions: review each one before running it.
Loading voting…