Skip to content

← Actionable
High, CVSS 8.1amended

MobSF has Stored XSS via Manifest Analysis - Dialer Code Host Field

CVE-2026-24490GHSA-8hf7-h89p-3pqj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mobsf 4.4.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI mobsf

    Affected
    < 4.4.5
    Fixed in
    4.4.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:N
EPSS
  • CVE-2026-24490: 0.35% estimated exploitation activity in the next 30 days; percentile 28.56 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A Stored Cross-site Scripting (XSS) vulnerability in MobSF's Android manifest analysis allows an attacker to execute arbitrary JavaScript in the context of a victim's browser session by uploading a malicious APK. The android:host attribute from <data android:scheme="androidsecretcode" elements is rendered in HTML reports without sanitization, enabling session hijacking and account takeover. Details When MobSF analyzes an Android APK containing a <data element with android:scheme="androidsecretcode", it extracts the android:host attribute and inserts it directly into the analysis report without HTML escaping. Vulnerable Code Path 1. Data Extraction - mobsf/StaticAnalyzer/views/android/manifestanalysis.py (line 776): 2. Template String Formatting - mobsf/StaticAnalyzer/views/android/manifestanalysis.py (line 806): 3. Template Definition - mobsf/StaticAnalyzer/views/android/kb/androidmanifestdesc.py (line 200): 4. Unsafe Rendering -…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-8hf7-h89p-3pqj

  2. Revision 1 · created ·

    Published from osv record GHSA-8hf7-h89p-3pqj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-24490

Advisory: MobSF has Stored XSS via Manifest Analysis - Dialer Code Host Field
IDs: CVE-2026-24490, GHSA-8hf7-h89p-3pqj
Record: https://patchnext.com/advisories/cve-2026-24490 (revision 2, source checked 26 Oct 2026, 13:36 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mobsf 4.4.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI mobsf: affected < 4.4.5; fixed in 4.4.5

## Suggested inspection (read-only)
- `python -m pip show mobsf`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mobsf.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-8hf7-h89p-3pqj (OSV record GHSA-8hf7-h89p-3pqj lists affected ranges: PyPI mobsf >=0 <4.4.5 (fixed))
- Verified: https://github.com/advisories/GHSA-8hf7-h89p-3pqj (GitHub-reviewed advisory GHSA-8hf7-h89p-3pqj lists affected ranges: PyPI mobsf >=0 <4.4.5)

Commands are suggestions: review each one before running it.

Loading voting…