Python-Multipart has Arbitrary File Write via Non-Default Configuration
CVE-2026-24486GHSA-wp53-j4wj-2cfg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (python-multipart 0.0.22), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI python-multipart
- Affected
- < 0.0.22
- Fixed in
- 0.0.22
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-wp53-j4wj-2cfg lists affected ranges: PyPI python-multipart >=0 <0.0.22 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wp53-j4wj-2cfg lists affected ranges: PyPI python-multipart >=0 <0.0.22
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:L
- EPSS
- CVE-2026-24486: 2.21% estimated exploitation activity in the next 30 days; percentile 82.59 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A Path Traversal vulnerability exists when using non-default configuration options UPLOADDIR and UPLOADKEEPFILENAME=True. An attacker can write uploaded files to arbitrary locations on the filesystem by crafting a malicious filename. Details When UPLOADDIR is set and UPLOADKEEPFILENAME is True, the library constructs the file path using os.path.join(filedir, fname). Due to the behavior of os.path.join(), if the filename begins with a /, all preceding path components are discarded: This allows an attacker to bypass the intended upload directory and write files to arbitrary paths. Affected Configuration Projects are only affected if all of the following are true: - UPLOADDIR is set - UPLOADKEEPFILENAME is set to True - The uploaded file exceeds MAXMEMORYFILESIZE (triggering a flush to disk) The default configuration is not vulnerable. Impact Arbitrary file write to attacker-controlled paths on the filesystem. Mitigation Upgrade to version 0.0.22, or avoid using…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-wp53-j4wj-2cfg
- Revision 1 · created ·
Published from osv record GHSA-wp53-j4wj-2cfg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-24486 Advisory: Python-Multipart has Arbitrary File Write via Non-Default Configuration IDs: CVE-2026-24486, GHSA-wp53-j4wj-2cfg Record: https://patchnext.com/advisories/cve-2026-24486 (revision 2, source checked 26 Oct 2026, 13:36 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: python-multipart 0.0.22. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI python-multipart: affected < 0.0.22; fixed in 0.0.22 ## Suggested inspection (read-only) - `python -m pip show python-multipart`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on python-multipart. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-wp53-j4wj-2cfg (OSV record GHSA-wp53-j4wj-2cfg lists affected ranges: PyPI python-multipart >=0 <0.0.22 (fixed)) - Verified: https://github.com/advisories/GHSA-wp53-j4wj-2cfg (GitHub-reviewed advisory GHSA-wp53-j4wj-2cfg lists affected ranges: PyPI python-multipart >=0 <0.0.22) Commands are suggestions: review each one before running it.
Loading voting…