Skip to content

← Actionable
Medium, CVSS 5.3

phpMyFAQ: Public API endpoints expose emails and invisible questions

CVE-2026-24422GHSA-j4rc-96xj-gvqc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (phpmyfaq/phpmyfaq 4.0.17; thorsten/phpmyfaq 4.0.17), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2026-24422: 0.41% estimated exploitation activity in the next 30 days; percentile 35.12 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Several public API endpoints return email addresses and non‑public records (e.g. open questions with isVisible=false). Details OpenQuestionController::list() calls Question::getAll() with the default showAll=true, returning invisible questions and their emails. Similar exposures exist in comment/news/faq APIs. PoC Impact Privacy exposure of email addresses and non‑public content; increased risk of phishing/scraping.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-j4rc-96xj-gvqc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-24422

Advisory: phpMyFAQ: Public API endpoints expose emails and invisible questions
IDs: CVE-2026-24422, GHSA-j4rc-96xj-gvqc
Record: https://patchnext.com/advisories/cve-2026-24422 (revision 1, source checked 26 Oct 2026, 14:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: phpmyfaq/phpmyfaq 4.0.17; thorsten/phpmyfaq 4.0.17. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist phpmyfaq/phpmyfaq: affected <= 4.0.16; fixed in 4.0.17
- Packagist thorsten/phpmyfaq: affected <= 4.0.16; fixed in 4.0.17

## Suggested inspection (read-only)
- Packagist phpmyfaq/phpmyfaq: check the installed version with your package manager.
- Packagist thorsten/phpmyfaq: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on phpmyfaq/phpmyfaq, thorsten/phpmyfaq.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-j4rc-96xj-gvqc (GitHub-reviewed advisory GHSA-j4rc-96xj-gvqc lists affected ranges: Packagist phpmyfaq/phpmyfaq >=0 =0 <=4.0.16)

Commands are suggestions: review each one before running it.

Loading voting…