Skip to content

← Actionable
Medium, CVSS 5.1

OpenSTAManager Affected by XSS in modifica_iva.php via righe parameter

CVE-2026-24415GHSA-jfgp-g7x7-j25j

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (devcode-it/openstamanager 2.9.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-24415: 0.28% estimated exploitation activity in the next 30 days; percentile 20.95 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Multiple Reflected Cross-Site Scripting (XSS) vulnerabilities in OpenSTAManager v2.9.8 allow unauthenticated attackers to execute arbitrary JavaScript code in the context of other users' browsers through crafted URL parameters, potentially leading to session hijacking, credential theft, and unauthorized actions. Vulnerable Parameter: righe (GET) Details OpenSTAManager v2.9.8 contains multiple Reflected XSS vulnerabilities in invoice/order/contract modification modals. The application fails to properly sanitize user-supplied input from the righe GET parameter before reflecting it in HTML output. Vulnerable Code Location: File: /modules/contratti/modals/modificaiva.php (Line 125) The $GET['righe'] parameter is directly echoed into the HTML value attribute without any sanitization using htmlspecialchars() or equivalent functions. This allows an attacker to break out of the attribute context and inject arbitrary HTML/JavaScript. All Affected Files: 1.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-jfgp-g7x7-j25j

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-24415

Advisory: OpenSTAManager Affected by XSS in modifica_iva.php via righe parameter
IDs: CVE-2026-24415, GHSA-jfgp-g7x7-j25j
Record: https://patchnext.com/advisories/cve-2026-24415 (revision 1, source checked 26 Oct 2026, 14:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: devcode-it/openstamanager 2.9.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist devcode-it/openstamanager: affected < 2.9.8; fixed in 2.9.8

## Suggested inspection (read-only)
- Packagist devcode-it/openstamanager: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on devcode-it/openstamanager.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-jfgp-g7x7-j25j (GitHub-reviewed advisory GHSA-jfgp-g7x7-j25j lists affected ranges: Packagist devcode-it/openstamanager >=0 <2.9.8)

Commands are suggestions: review each one before running it.

Loading voting…