NVIDIA NVFlare Dashboard: Authorization bypass through user-controlled key via user management and authentication system
CVE-2026-24178GHSA-jqp3-qrgh-4846
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (nvflare 2.7.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI nvflare
- Affected
- < 2.7.2
- Fixed in
- 2.7.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jqp3-qrgh-4846 lists affected ranges: PyPI nvflare >=0 <2.7.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-jqp3-qrgh-4846 lists affected ranges: PyPI nvflare >=0 <2.7.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-24178: 0.57% estimated exploitation activity in the next 30 days; percentile 47.39 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
NVIDIA NVFlare Dashboard contains a vulnerability in the user management and authentication system where an unauthenticated attacker may cause authorization bypass through user-controlled key. A successful exploit of this vulnerability may lead to privilege escalation, data tampering, information disclosure, code execution, and denial of service.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-jqp3-qrgh-4846
- Revision 2 · amended ·
Amended from osv record GHSA-jqp3-qrgh-4846
- Revision 1 · created ·
Published from ghsa record GHSA-jqp3-qrgh-4846
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-24178 Advisory: NVIDIA NVFlare Dashboard: Authorization bypass through user-controlled key via user management and authentication system IDs: CVE-2026-24178, GHSA-jqp3-qrgh-4846 Record: https://patchnext.com/advisories/cve-2026-24178 (revision 3, source checked 26 Oct 2026, 13:45 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: nvflare 2.7.2. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI nvflare: affected < 2.7.2; fixed in 2.7.2 ## Suggested inspection (read-only) - `python -m pip show nvflare`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on nvflare. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-jqp3-qrgh-4846 (GitHub-reviewed advisory GHSA-jqp3-qrgh-4846 lists affected ranges: PyPI nvflare >=0 <2.7.2) - Verified: https://osv.dev/vulnerability/GHSA-jqp3-qrgh-4846 (OSV record GHSA-jqp3-qrgh-4846 lists affected ranges: PyPI nvflare >=0 <2.7.2 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…