Skip to content

← Actionable
High, CVSS 7.5amended

pretix unsafely evaluates variables in emails

CVE-2026-2415GHSA-r8p8-qw9w-j9qv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pretix 2026.1.1, 2025.10.2, 2025.9.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI pretix

    Affected
    >= 2026.1.0, < 2026.1.1>= 2025.10.0, < 2025.10.2< 2025.9.4
    Fixed in
    2025.9.4, 2026.1.1, 2025.10.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.5 · CVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H/E:P/RE:L/U:Red · score source
EPSS
  • CVE-2026-2415: 0.29% estimated exploitation activity in the next 30 days; percentile 21.11 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Emails sent by pretix can utilize placeholders that will be filled with customer data. For example, when {name} is used in an email template, it will be replaced with the buyer's name for the final email. This mechanism contained two security-relevant bugs: - It was possible to exfiltrate information about the pretix system through specially crafted placeholder names such as {event.init.code.cofilename}}. This way, an attacker with the ability to control email templates (usually every user of the pretix backend) could retrieve sensitive information from the system configuration, including even database passwords or API keys. pretix does include mechanisms to prevent the usage of such malicious placeholders, however due to a mistake in the code, they were not fully effective for the email subject. - Placeholders in subjects and plain text bodies of emails were wrongfully evaluated twice. Therefore, if the first evaluation of a placeholder again contains a placeholder, this second…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-r8p8-qw9w-j9qv

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-r8p8-qw9w-j9qv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-2415

Advisory: pretix unsafely evaluates variables in emails
IDs: CVE-2026-2415, GHSA-r8p8-qw9w-j9qv
Record: https://patchnext.com/advisories/cve-2026-2415 (revision 3, source checked 26 Oct 2026, 13:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pretix 2026.1.1, 2025.10.2, 2025.9.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI pretix: affected >= 2026.1.0, < 2026.1.1; >= 2025.10.0, < 2025.10.2; < 2025.9.4; fixed in 2025.9.4, 2026.1.1, 2025.10.2

## Suggested inspection (read-only)
- `python -m pip show pretix`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pretix.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-r8p8-qw9w-j9qv (OSV record GHSA-r8p8-qw9w-j9qv lists affected ranges: PyPI pretix >=2026.1.0 =2025.10.0 =0 <2025.9.4 (fixed))
- Verified: https://github.com/advisories/GHSA-r8p8-qw9w-j9qv (GitHub-reviewed advisory GHSA-r8p8-qw9w-j9qv lists affected ranges: PyPI pretix >=2026.1.0 =2025.10.0 =0 <2025.9.4)

Commands are suggestions: review each one before running it.

Loading voting…