pnpm has Path Traversal via arbitrary file permission modification
CVE-2026-24131GHSA-v253-rj99-jwpq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pnpm 10.28.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm pnpm
- Affected
- < 10.28.2
- Fixed in
- 10.28.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-v253-rj99-jwpq lists affected ranges: npm pnpm >=0 <10.28.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-v253-rj99-jwpq lists affected ranges: npm pnpm >=0 <10.28.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.7 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-24131: 0.27% estimated exploitation activity in the next 30 days; percentile 19.39 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary When pnpm processes a package's directories.bin field, it uses path.join() without validating the result stays within the package root. A malicious npm package can specify "directories": {"bin": "../../../../tmp"} to escape the package directory, causing pnpm to chmod 755 files at arbitrary locations. Note: Only affects Unix/Linux/macOS. Windows is not affected (fixBin gated by EXECUTABLESHEBANGSUPPORTED). Details Vulnerable code in pkg-manager/package-bins/src/index.ts:15-21: The bin field IS protected with isSubdir() at line 53, but directories.bin lacks this check. PoC Impact - Supply-chain attack via npm packages - File permissions changed from 600 to 755 (world-readable) - Affects non-dotfiles in predictable paths (dotfiles excluded by tinyglobby default) Suggested Fix Add isSubdir validation for directories.bin paths in pkg-manager/package-bins/src/index.ts, matching the existing validation in commandsFromBin():
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-v253-rj99-jwpq
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-v253-rj99-jwpq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-24131 Advisory: pnpm has Path Traversal via arbitrary file permission modification IDs: CVE-2026-24131, GHSA-v253-rj99-jwpq Record: https://patchnext.com/advisories/cve-2026-24131 (revision 3, source checked 26 Oct 2026, 12:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pnpm 10.28.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm pnpm: affected < 10.28.2; fixed in 10.28.2 ## Suggested inspection (read-only) - `npm ls pnpm --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pnpm. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-v253-rj99-jwpq (OSV record GHSA-v253-rj99-jwpq lists affected ranges: npm pnpm >=0 <10.28.2 (fixed)) - Verified: https://github.com/advisories/GHSA-v253-rj99-jwpq (GitHub-reviewed advisory GHSA-v253-rj99-jwpq lists affected ranges: npm pnpm >=0 <10.28.2) Commands are suggestions: review each one before running it.
Loading voting…