Skip to content

← Actionable
Low, CVSS 2.7amended

Moonraker affected by LDAP search filter injection

CVE-2026-24130GHSA-3jqf-v4mv-747g

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (moonraker 0.10.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
2.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:U · score source
EPSS
  • CVE-2026-24130: 0.30% estimated exploitation activity in the next 30 days; percentile 23.01 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Instances of Moonraker configured with the ldap component enabled are vulnerable to LDAP search filter injection techniques via the login endpoint. The 401 error response message can be used to determine whether or not a search was successful, allowing for brute force methods to discover LDAP entries on the server such as user IDs and user attributes. Patches Users should upgrade to Moonraker 0.10.0 which patches this vulnerability. Workarounds Admins can set the maxloginattempts option in the [authorization] section to a reasonable value. Any IP attempting to exploit this vulnerability will be locked out after it has reached the specified number of consecutive failed login attempts. This condition is cleared after a Moonraker restart. Note that if an attacker knows a valid user password they can bypass this protection by successfully logging in. The most secure workaround for users unable to upgrade is to remove the ldap section from moonraker.conf and rely on the built in…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-3jqf-v4mv-747g

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-3jqf-v4mv-747g

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-24130

Advisory: Moonraker affected by LDAP search filter injection
IDs: CVE-2026-24130, GHSA-3jqf-v4mv-747g
Record: https://patchnext.com/advisories/cve-2026-24130 (revision 3, source checked 26 Oct 2026, 13:36 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: moonraker 0.10.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI moonraker: affected < 0.10.0; fixed in 0.10.0

## Suggested inspection (read-only)
- `python -m pip show moonraker`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on moonraker.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-3jqf-v4mv-747g (OSV record GHSA-3jqf-v4mv-747g lists affected ranges: PyPI moonraker >=0 <0.10.0 (fixed))
- Verified: https://github.com/advisories/GHSA-3jqf-v4mv-747g (GitHub-reviewed advisory GHSA-3jqf-v4mv-747g lists affected ranges: PyPI moonraker >=0 <0.10.0)

Commands are suggestions: review each one before running it.

Loading voting…