XWiki Affected by Reflected Cross-Site Scripting (XSS) in Error Messages
CVE-2026-24128GHSA-wvqx-m5px-6cmp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.xwiki.platform:xwiki-platform-web-templates 17.8.0-rc-1, 17.4.5, 16.10.12), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.xwiki.platform:xwiki-platform-web-templates
- Affected
- >= 7.0-milestone-2, < 16.10.12>= 17.0.0-rc-1, < 17.4.5>= 17.5.0-rc-1, < 17.8.0-rc-1
- Fixed in
- 16.10.12, 17.8.0-rc-1, 17.4.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wvqx-m5px-6cmp lists affected ranges: Maven org.xwiki.platform:xwiki-platform-web-templates >=7.0-milestone-2 =17.0.0-rc-1 =17.5.0-rc-1 <17.8.0-rc-1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.5 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H · score source
- EPSS
- CVE-2026-24128: 0.55% estimated exploitation activity in the next 30 days; percentile 46.14 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A reflected cross site scripting (XSS) vulnerability in XWiki allows an attacker to execute arbitrary actions in XWiki with the rights of the victim if the attacker manages to trick a victim into visiting a crafted URL. If the victim has administrative or programming rights, those rights can be exploited to gain full access to the XWiki installation. Patches This vulnerability has been patched in XWiki 17.8.0RC1, 17.4.5 and 16.10.12. Workarounds The patch can be applied manually, only a single line in templates/loggingmacros.vm needs to be changed, no restart is required. References https://github.com/xwiki/xwiki-platform/commit/8337ac8c3b19c37f306723b638b2cae8b0a57dbf https://jira.xwiki.org/browse/XWIKI-23462 Attribution We thank Mike Cole @mikecole-mg for discovering and reporting this vulnerability.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-wvqx-m5px-6cmp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-24128 Advisory: XWiki Affected by Reflected Cross-Site Scripting (XSS) in Error Messages IDs: CVE-2026-24128, GHSA-wvqx-m5px-6cmp Record: https://patchnext.com/advisories/cve-2026-24128 (revision 1, source checked 26 Oct 2026, 16:44 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.xwiki.platform:xwiki-platform-web-templates 17.8.0-rc-1, 17.4.5, 16.10.12. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.xwiki.platform:xwiki-platform-web-templates: affected >= 7.0-milestone-2, < 16.10.12; >= 17.0.0-rc-1, < 17.4.5; >= 17.5.0-rc-1, < 17.8.0-rc-1; fixed in 16.10.12, 17.8.0-rc-1, 17.4.5 ## Suggested inspection (read-only) - Maven org.xwiki.platform:xwiki-platform-web-templates: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.xwiki.platform:xwiki-platform-web-templates. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-wvqx-m5px-6cmp (GitHub-reviewed advisory GHSA-wvqx-m5px-6cmp lists affected ranges: Maven org.xwiki.platform:xwiki-platform-web-templates >=7.0-milestone-2 =17.0.0-rc-1 =17.5.0-rc-1 <17.8.0-rc-1) Commands are suggestions: review each one before running it.
Loading voting…