Skip to content

← Actionable
Medium, CVSS 6.6amended

Weblate has an argument injection in management console

CVE-2026-24126GHSA-33fm-6gp7-4p47

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (weblate 5.16.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI weblate

    Affected
    < 5.16.0
    Fixed in
    5.16.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.6 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:L
EPSS
  • CVE-2026-24126: 0.52% estimated exploitation activity in the next 30 days; percentile 44.14 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The SSH management console did not validate the passed input while adding the SSH host key, which could lead to an argument injection to ssh-add. Patches https://github.com/WeblateOrg/weblate/pull/17722 Workarounds Properly limit access to the management console. References This issue was reported to us by alexb616 via HackerOne.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-33fm-6gp7-4p47

  2. Revision 1 · created ·

    Published from osv record GHSA-33fm-6gp7-4p47

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-24126

Advisory: Weblate has an argument injection in management console
IDs: CVE-2026-24126, GHSA-33fm-6gp7-4p47
Record: https://patchnext.com/advisories/cve-2026-24126 (revision 2, source checked 26 Oct 2026, 13:36 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: weblate 5.16.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI weblate: affected < 5.16.0; fixed in 5.16.0

## Suggested inspection (read-only)
- `python -m pip show weblate`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on weblate.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-33fm-6gp7-4p47 (OSV record GHSA-33fm-6gp7-4p47 lists affected ranges: PyPI weblate >=0 <5.16.0 (fixed))
- Verified: https://github.com/advisories/GHSA-33fm-6gp7-4p47 (GitHub-reviewed advisory GHSA-33fm-6gp7-4p47 lists affected ranges: PyPI weblate >=0 <5.16.0)

Commands are suggestions: review each one before running it.

Loading voting…