BentoML has a Path Traversal via Bentofile Configuration
CVE-2026-24123GHSA-6r62-w2q3-48hf
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (bentoml 1.4.34), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI bentoml
- Affected
- < 1.4.34
- Fixed in
- 1.4.34
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-6r62-w2q3-48hf lists affected ranges: PyPI bentoml >=0 <1.4.34 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6r62-w2q3-48hf lists affected ranges: PyPI bentoml >=0 <1.4.34
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.4 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:N/A:N
- EPSS
- CVE-2026-24123: 0.49% estimated exploitation activity in the next 30 days; percentile 42.27 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary BentoML's bentofile.yaml configuration allows path traversal attacks through multiple file path fields (description, docker.setupscript, docker.dockerfiletemplate, conda.environmentyml). An attacker can craft a malicious bentofile that, when built by a victim, exfiltrates arbitrary files from the filesystem into the bento archive. This enables supply chain attacks where sensitive files (SSH keys, credentials, environment variables) are silently embedded in bentos and exposed when pushed to registries or deployed. Details The vulnerability exists in how BentoML resolves user-provided file paths without validating that they remain within the build context directory. Vulnerable function in src/bentoml/internal/utils/filesystem.py:114-131: Vulnerable code in src/bentoml/internal/bento/bento.py:348-355: All four vulnerable fields: - description: "file:../../../etc/passwd" → copied to README.md - docker.setupscript: "../../../etc/passwd" → copied to env/docker/setupscript -…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-6r62-w2q3-48hf
- Revision 1 · created ·
Published from osv record GHSA-6r62-w2q3-48hf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-24123 Advisory: BentoML has a Path Traversal via Bentofile Configuration IDs: CVE-2026-24123, GHSA-6r62-w2q3-48hf Record: https://patchnext.com/advisories/cve-2026-24123 (revision 2, source checked 26 Oct 2026, 13:36 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: bentoml 1.4.34. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI bentoml: affected < 1.4.34; fixed in 1.4.34 ## Suggested inspection (read-only) - `python -m pip show bentoml`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on bentoml. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-6r62-w2q3-48hf (OSV record GHSA-6r62-w2q3-48hf lists affected ranges: PyPI bentoml >=0 <1.4.34 (fixed)) - Verified: https://github.com/advisories/GHSA-6r62-w2q3-48hf (GitHub-reviewed advisory GHSA-6r62-w2q3-48hf lists affected ranges: PyPI bentoml >=0 <1.4.34) Commands are suggestions: review each one before running it.
Loading voting…