Skip to content

← Actionable
Critical, CVSS 9.8amended

VM2 Has Sandbox Breakout Through Promise Species

CVE-2026-24120GHSA-qvjj-29qf-hp7p

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (vm2 3.10.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm vm2

    Affected
    <= 3.10.3
    Fixed in
    3.10.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-24120: 0.90% estimated exploitation activity in the next 30 days; percentile 59.60 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The fix for https://github.com/patriksimek/vm2/security/advisories/GHSA-cchq-frgv-rjh5 is insufficient and can be circumvented allowing attackers to write code which can escape from the VM2 sandbox and execute arbitrary commands on the host system. Details The fix for https://github.com/patriksimek/vm2/security/advisories/GHSA-cchq-frgv-rjh5 introduced the function resetPromiseSpecies https://github.com/patriksimek/vm2/blob/4b009c2d4b1131c01810c1205e641d614c322a29/lib/setup-sandbox.js#L35C7-L39. This function changes the species property of promise objects back to a known value. However, it uses the function [].includes and Object.defineProperty which can be overewritten to prevent the species from being changed. PoC The following code demonstrates this issue by aquiring the host process object and executing touch pwned. Impact Attackers can perform Remote Code Execution under the assumption that the attacker can run arbitrary code execution inside the context of a vm2 sandbox.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-qvjj-29qf-hp7p

  2. Revision 2 · amended ·

    Amended from osv record GHSA-qvjj-29qf-hp7p

  3. Revision 1 · created ·

    Published from ghsa record GHSA-qvjj-29qf-hp7p

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-24120

Advisory: VM2 Has Sandbox Breakout Through Promise Species
IDs: CVE-2026-24120, GHSA-qvjj-29qf-hp7p
Record: https://patchnext.com/advisories/cve-2026-24120 (revision 3, source checked 26 Oct 2026, 12:51 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: vm2 3.10.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm vm2: affected <= 3.10.3; fixed in 3.10.5

## Suggested inspection (read-only)
- `npm ls vm2 --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on vm2.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-qvjj-29qf-hp7p (GitHub-reviewed advisory GHSA-qvjj-29qf-hp7p lists affected ranges: npm vm2 >=0 <=3.10.3)
- Verified: https://osv.dev/vulnerability/GHSA-qvjj-29qf-hp7p (OSV record GHSA-qvjj-29qf-hp7p lists affected ranges: npm vm2 >=0 <3.10.5 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…