Skip to content

← Actionable
Critical, CVSS 9.8amended

VM2 Sandbox Breakout Through __lookupGetter__

CVE-2026-24118GHSA-grj5-jjm8-h35p

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (vm2 3.11.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm vm2

    Affected
    < 3.11.0
    Fixed in
    3.11.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-24118: 0.91% estimated exploitation activity in the next 30 days; percentile 59.90 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary VM2 suffers from a sandbox breakout vulnerability. This allows attackers to write code which can escape from the VM2 sandbox and execute arbitrary commands on the host system.

Details The `lookupGetter` method allows to read the getter of an object. It is special in VM2 since it will switch between the host and sandbox version of the method when passed to the other context. This allows to access getters on an object in the host context if the method is called from the host context which can be achieved by using the host `apply` method which can be accessed through `Buffer.apply`. Afterwards, this function can be used to call the host version of `lookupGetter` with `Buffer` and `proto` resulting in the prototype lookup method from the host context. With this method the hosts `Function.prototype` object can be retrieved and the host `Function` acquired through the `constructor` property which allows to create and run code in the host context. This issue was…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 5 · amended ·

    Amended from osv record GHSA-grj5-jjm8-h35p

  2. Revision 4 · amended ·

    Amended from ghsa record GHSA-grj5-jjm8-h35p

  3. Revision 3 · amended ·

    Amended from ghsa record GHSA-grj5-jjm8-h35p

  4. Revision 2 · amended ·

    Amended from osv record GHSA-grj5-jjm8-h35p

  5. Revision 1 · created ·

    Published from ghsa record GHSA-grj5-jjm8-h35p

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-24118

Advisory: VM2 Sandbox Breakout Through __lookupGetter__
IDs: CVE-2026-24118, GHSA-grj5-jjm8-h35p
Record: https://patchnext.com/advisories/cve-2026-24118 (revision 5, source checked 4 Nov 2026, 06:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: vm2 3.11.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm vm2: affected < 3.11.0; fixed in 3.11.0

## Suggested inspection (read-only)
- `npm ls vm2 --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on vm2.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-grj5-jjm8-h35p (GitHub-reviewed advisory GHSA-grj5-jjm8-h35p lists affected ranges: npm vm2 >=0 <=3.10.4)
- Verified: https://osv.dev/vulnerability/GHSA-grj5-jjm8-h35p (OSV record GHSA-grj5-jjm8-h35p lists affected ranges: npm vm2 >=0 <3.11.0 (fixed))
- Verified: https://github.com/advisories/GHSA-grj5-jjm8-h35p (GitHub-reviewed advisory GHSA-grj5-jjm8-h35p lists affected ranges: npm vm2 >=0 <3.11.0)

Commands are suggestions: review each one before running it.

Loading voting…