Apache Airflow UI Exposes DAG Import Errors to Unauthorized Authenticated Users
CVE-2026-24098GHSA-5g2w-9f8g-g5q7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (apache-airflow 3.1.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI apache-airflow
- Affected
- < 3.1.7
- Fixed in
- 3.1.7
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-5g2w-9f8g-g5q7 lists affected ranges: PyPI apache-airflow >=0 <3.1.7 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5g2w-9f8g-g5q7 lists affected ranges: PyPI apache-airflow >=0 <3.1.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2026-24098: 0.83% estimated exploitation activity in the next 30 days; percentile 57.51 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Exposure of Sensitive Information: An information disclosure vulnerability exists in the Apache Airflow UI that allows authenticated users to view Import Errors for DAGs they are not authorized to access. In affected versions, the Import Errors view does not correctly filter errors based on granular DAG permissions. This means a user with access to only DAGA can view import errors generated by DAGB, DAGC, or system-level DAGs. These error logs often contain file paths, code snippets, or stack traces that reveal the internal structure and logic of restricted DAGs. Patches Users should upgrade to Apache Airflow 3.1.7 or later. This version strictly enforces DAG-level permissions on the Import Errors view. Workarounds There are no known workarounds other than upgrading. Resources CVE-2026-24098 Pull Request #60801 Mailing List Announcement
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-5g2w-9f8g-g5q7
- Revision 1 · created ·
Published from osv record GHSA-5g2w-9f8g-g5q7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-24098 Advisory: Apache Airflow UI Exposes DAG Import Errors to Unauthorized Authenticated Users IDs: CVE-2026-24098, GHSA-5g2w-9f8g-g5q7 Record: https://patchnext.com/advisories/cve-2026-24098 (revision 2, source checked 26 Oct 2026, 13:36 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: apache-airflow 3.1.7. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI apache-airflow: affected < 3.1.7; fixed in 3.1.7 ## Suggested inspection (read-only) - `python -m pip show apache-airflow`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on apache-airflow. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-5g2w-9f8g-g5q7 (OSV record GHSA-5g2w-9f8g-g5q7 lists affected ranges: PyPI apache-airflow >=0 <3.1.7 (fixed)) - Verified: https://github.com/advisories/GHSA-5g2w-9f8g-g5q7 (GitHub-reviewed advisory GHSA-5g2w-9f8g-g5q7 lists affected ranges: PyPI apache-airflow >=0 <3.1.7) Commands are suggestions: review each one before running it.
Loading voting…