Soft Serve Affected by an Authentication Bypass
CVE-2026-24058GHSA-pchf-49fh-w34r
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/charmbracelet/soft-serve 0.11.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/charmbracelet/soft-serve
- Affected
- <= 0.11.2
- Fixed in
- 0.11.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pchf-49fh-w34r lists affected ranges: Go github.com/charmbracelet/soft-serve >=0 <=0.11.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U · score source
- EPSS
- CVE-2026-24058: 0.58% estimated exploitation activity in the next 30 days; percentile 47.66 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact What kind of vulnerability is it? Who is impacted? This issue impacts every Soft Serve instance. A critical authentication bypass allows an attacker to impersonate any user (including Admin) by "offering" the victim's public key during the SSH handshake before authenticating with their own valid key. This occurs because the user identity is stored in the session context during the "offer" phase and is not cleared if that specific authentication attempt fails. Patches Has the problem been patched? What versions should users upgrade to? Yes, please upgrade to version 0.11.3 as soon as possible. Workarounds Is there a way for users to fix or remediate the vulnerability without upgrading? You need to upgrade
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-pchf-49fh-w34r
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-24058 Advisory: Soft Serve Affected by an Authentication Bypass IDs: CVE-2026-24058, GHSA-pchf-49fh-w34r Record: https://patchnext.com/advisories/cve-2026-24058 (revision 1, source checked 26 Oct 2026, 15:14 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/charmbracelet/soft-serve 0.11.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/charmbracelet/soft-serve: affected <= 0.11.2; fixed in 0.11.3 ## Suggested inspection (read-only) - Go github.com/charmbracelet/soft-serve: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/charmbracelet/soft-serve. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-pchf-49fh-w34r (GitHub-reviewed advisory GHSA-pchf-49fh-w34r lists affected ranges: Go github.com/charmbracelet/soft-serve >=0 <=0.11.2) Commands are suggestions: review each one before running it.
Loading voting…