Skip to content

← Actionable
Medium, CVSS 6.7amended

pnpm has symlink traversal in file:/git dependencies

CVE-2026-24056GHSA-m733-5w8f-5ggw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pnpm 10.28.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm pnpm

    Affected
    < 10.28.2
    Fixed in
    10.28.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.7 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-24056: 0.52% estimated exploitation activity in the next 30 days; percentile 44.41 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary When pnpm installs a file: (directory) or git: dependency, it follows symlinks and reads their target contents without constraining them to the package root. A malicious package containing a symlink to an absolute path (e.g., /etc/passwd, ~/.ssh/idrsa) causes pnpm to copy that file's contents into nodemodules, leaking local data. Preconditions: Only affects file: and git: dependencies. Registry packages (npm) have symlinks stripped during publish and are NOT affected. Details The vulnerability exists in store/cafs/src/addFilesFromDir.ts. The code uses fs.statSync() and readFileSync() which follow symlinks by default: There is no check that absolutePath resolves to a location inside the package directory. PoC Impact - Developers installing local/file dependencies - CI/CD pipelines installing git dependencies - Credential theft via symlinks to ~/.aws/credentials, ~/.npmrc, ~/.ssh/idrsa Suggested Fix Use lstatSync to detect symlinks and reject those pointing outside the package…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-m733-5w8f-5ggw

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-m733-5w8f-5ggw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-24056

Advisory: pnpm has symlink traversal in file:/git dependencies
IDs: CVE-2026-24056, GHSA-m733-5w8f-5ggw
Record: https://patchnext.com/advisories/cve-2026-24056 (revision 3, source checked 26 Oct 2026, 12:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pnpm 10.28.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm pnpm: affected < 10.28.2; fixed in 10.28.2

## Suggested inspection (read-only)
- `npm ls pnpm --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pnpm.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-m733-5w8f-5ggw (OSV record GHSA-m733-5w8f-5ggw lists affected ranges: npm pnpm >=0 <10.28.2 (fixed))
- Verified: https://github.com/advisories/GHSA-m733-5w8f-5ggw (GitHub-reviewed advisory GHSA-m733-5w8f-5ggw lists affected ranges: npm pnpm >=0 <10.28.2)

Commands are suggestions: review each one before running it.

Loading voting…