Claude Code has a Domain Validation Bypass which Allows Automatic Requests to Attacker-Controlled Domains
CVE-2026-24052GHSA-vhw5-3g5m-8ggf
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@anthropic-ai/claude-code 1.0.111), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 1.0.111
- Fixed in
- 1.0.111
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-vhw5-3g5m-8ggf lists affected ranges: npm @anthropic-ai/claude-code >=0 <1.0.111 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vhw5-3g5m-8ggf lists affected ranges: npm @anthropic-ai/claude-code >=0 <1.0.111
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-24052: 0.43% estimated exploitation activity in the next 30 days; percentile 37.60 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Claude Code contained insufficient URL validation in its trusted domain verification mechanism for WebFetch requests. The application used a startsWith() function to validate trusted domains (e.g., docs.python.org, modelcontextprotocol.io), this could have enabled attackers to register domains like modelcontextprotocol.io.example.com that would pass validation. This could enable automatic requests to attacker-controlled domains without user consent, potentially leading to data exfiltration. Users on standard Claude Code auto-update have received this fix already. Users performing manual updates are advised to update to the latest version. Thank you to hackerone.com/47sid-praetorian for reporting this issue!
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-vhw5-3g5m-8ggf
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-vhw5-3g5m-8ggf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-24052 Advisory: Claude Code has a Domain Validation Bypass which Allows Automatic Requests to Attacker-Controlled Domains IDs: CVE-2026-24052, GHSA-vhw5-3g5m-8ggf Record: https://patchnext.com/advisories/cve-2026-24052 (revision 3, source checked 26 Oct 2026, 12:42 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @anthropic-ai/claude-code 1.0.111. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @anthropic-ai/claude-code: affected < 1.0.111; fixed in 1.0.111 ## Suggested inspection (read-only) - `npm ls @anthropic-ai/claude-code --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @anthropic-ai/claude-code. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-vhw5-3g5m-8ggf (OSV record GHSA-vhw5-3g5m-8ggf lists affected ranges: npm @anthropic-ai/claude-code >=0 <1.0.111 (fixed)) - Verified: https://github.com/advisories/GHSA-vhw5-3g5m-8ggf (GitHub-reviewed advisory GHSA-vhw5-3g5m-8ggf lists affected ranges: npm @anthropic-ai/claude-code >=0 <1.0.111) Commands are suggestions: review each one before running it.
Loading voting…