Backstage has a Possible SSRF when reading from allowed URL's in backend.reading.allow
CVE-2026-24048GHSA-q2x5-4xjx-c6p9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@backstage/backend-defaults 0.14.1, 0.13.2, 0.12.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @backstage/backend-defaults
- Affected
- < 0.12.2>= 0.13.0, < 0.13.2>= 0.14.0, < 0.14.1
- Fixed in
- 0.12.2, 0.13.2, 0.14.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-q2x5-4xjx-c6p9 lists affected ranges: npm @backstage/backend-defaults >=0 =0.13.0 =0.14.0 <0.14.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q2x5-4xjx-c6p9 lists affected ranges: npm @backstage/backend-defaults >=0 =0.13.0 =0.14.0 <0.14.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 3.5 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:N/A:N
- EPSS
- CVE-2026-24048: 0.24% estimated exploitation activity in the next 30 days; percentile 14.59 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The FetchUrlReader component, used by the catalog and other plugins to fetch content from URLs, followed HTTP redirects automatically. This allowed an attacker who controls a host listed in backend.reading.allow to redirect requests to internal or sensitive URLs that are not on the allowlist, bypassing the URL allowlist security control. This is a Server-Side Request Forgery (SSRF) vulnerability that could allow access to internal resources, but it does not allow attackers to include additional request headers. Patches This vulnerability is fixed in @backstage/backend-defaults version 0.12.2, 0.13.2, 0.14.1, and 0.15.0. Users should upgrade to this version or later. Workarounds - Restrict backend.reading.allow to only trusted hosts that you control and that do not issue redirects - Ensure allowed hosts do not have open redirect vulnerabilities - Use network-level controls to block access from Backstage to sensitive internal endpoints References - OWASP SSRF Prevention Cheat…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-q2x5-4xjx-c6p9
- Revision 1 · created ·
Published from osv record GHSA-q2x5-4xjx-c6p9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-24048 Advisory: Backstage has a Possible SSRF when reading from allowed URL's in `backend.reading.allow` IDs: CVE-2026-24048, GHSA-q2x5-4xjx-c6p9 Record: https://patchnext.com/advisories/cve-2026-24048 (revision 2, source checked 26 Oct 2026, 12:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 3.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @backstage/backend-defaults 0.14.1, 0.13.2, 0.12.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @backstage/backend-defaults: affected < 0.12.2; >= 0.13.0, < 0.13.2; >= 0.14.0, < 0.14.1; fixed in 0.12.2, 0.13.2, 0.14.1 ## Suggested inspection (read-only) - `npm ls @backstage/backend-defaults --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @backstage/backend-defaults. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-q2x5-4xjx-c6p9 (OSV record GHSA-q2x5-4xjx-c6p9 lists affected ranges: npm @backstage/backend-defaults >=0 =0.13.0 =0.14.0 <0.14.1 (fixed)) - Verified: https://github.com/advisories/GHSA-q2x5-4xjx-c6p9 (GitHub-reviewed advisory GHSA-q2x5-4xjx-c6p9 lists affected ranges: npm @backstage/backend-defaults >=0 =0.13.0 =0.14.0 <0.14.1) Commands are suggestions: review each one before running it.
Loading voting…