Skip to content

← Actionable
Medium, CVSS 6.3amended

@backstage/cli-common has a possible resolveSafeChildPath Symlink Chain Bypass

CVE-2026-24047GHSA-2p49-45hj-7mc9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@backstage/cli-common 0.1.17), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.3 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:N/A:N
EPSS
  • CVE-2026-24047: 0.53% estimated exploitation activity in the next 30 days; percentile 45.11 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The resolveSafeChildPath utility function in @backstage/backend-plugin-api, which is used to prevent path traversal attacks, failed to properly validate symlink chains and dangling symlinks. An attacker could bypass the path validation by: 1. Symlink chains: Creating link1 → link2 → /outside where intermediate symlinks eventually resolve outside the allowed directory 2. Dangling symlinks: Creating symlinks pointing to non-existent paths outside the base directory, which would later be created during file operations This function is used by Scaffolder actions and other backend components to ensure file operations stay within designated directories. Patches This vulnerability is fixed in @backstage/backend-plugin-api version 0.1.17. Users should upgrade to this version or later. Workarounds - Run Backstage in a containerised environment with limited filesystem access - Restrict template creation to trusted users

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-2p49-45hj-7mc9

  2. Revision 1 · created ·

    Published from osv record GHSA-2p49-45hj-7mc9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-24047

Advisory: @backstage/cli-common has a possible `resolveSafeChildPath` Symlink Chain Bypass
IDs: CVE-2026-24047, GHSA-2p49-45hj-7mc9
Record: https://patchnext.com/advisories/cve-2026-24047 (revision 2, source checked 26 Oct 2026, 12:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @backstage/cli-common 0.1.17. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @backstage/cli-common: affected <= 0.1.16; fixed in 0.1.17

## Suggested inspection (read-only)
- `npm ls @backstage/cli-common --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @backstage/cli-common.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-2p49-45hj-7mc9 (OSV record GHSA-2p49-45hj-7mc9 lists affected ranges: npm @backstage/cli-common >=0 <0.1.17 (fixed))
- Verified: https://github.com/advisories/GHSA-2p49-45hj-7mc9 (GitHub-reviewed advisory GHSA-2p49-45hj-7mc9 lists affected ranges: npm @backstage/cli-common >=0 <=0.1.16)

Commands are suggestions: review each one before running it.

Loading voting…