Backstage has a Possible Symlink Path Traversal in Scaffolder Actions
CVE-2026-24046GHSA-rq6q-wr2q-7pgp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@backstage/backend-defaults 0.14.1, 0.13.2, 0.12.2; @backstage/plugin-scaffolder-backend 3.1.1, 3.0.2, 2.2.2; @backstage/plugin-scaffolder-node 0.12.3, 0.11.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @backstage/backend-defaults
- Affected
- < 0.12.2>= 0.13.0, < 0.13.2>= 0.14.0, < 0.14.1
- Fixed in
- 0.12.2, 0.13.2, 0.14.1
npm @backstage/plugin-scaffolder-backend
- Affected
- < 2.2.2>= 3.0.0, < 3.0.2>= 3.1.0, < 3.1.1
- Fixed in
- 3.0.2, 3.1.1, 2.2.2
npm @backstage/plugin-scaffolder-node
- Affected
- < 0.11.2>= 0.12.0, < 0.12.3
- Fixed in
- 0.11.2, 0.12.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-rq6q-wr2q-7pgp lists affected ranges: npm @backstage/backend-defaults >=0 =0.13.0 =0.14.0 =0 =3.0.0 =3.1.0 =0 =0.12.0 <0.12.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rq6q-wr2q-7pgp lists affected ranges: npm @backstage/backend-defaults >=0 =0.13.0 =0.14.0 =0 =3.0.0 =3.1.0 =0 =0.12.0 <0.12.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.1 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:N/A:L
- EPSS
- CVE-2026-24046: 0.53% estimated exploitation activity in the next 30 days; percentile 44.54 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Multiple Scaffolder actions and archive extraction utilities were vulnerable to symlink-based path traversal attacks. An attacker with access to create and execute Scaffolder templates could exploit symlinks to: 1. Read arbitrary files via the debug:log action by creating a symlink pointing to sensitive files (e.g., /etc/passwd, configuration files, secrets) 2. Delete arbitrary files via the fs:delete action by creating symlinks pointing outside the workspace 3. Write files outside the workspace via archive extraction (tar/zip) containing malicious symlinks This affects any Backstage deployment where users can create or execute Scaffolder templates. Patches This vulnerability is fixed in the following package versions: - @backstage/backend-defaults version 0.12.2, 0.13.2, 0.14.1, 0.15.0 - @backstage/plugin-scaffolder-backend version 2.2.2, 3.0.2, 3.1.1 - @backstage/plugin-scaffolder-node version 0.11.2, 0.12.3 Users should upgrade to these versions or later. Workarounds -…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-rq6q-wr2q-7pgp
- Revision 1 · created ·
Published from osv record GHSA-rq6q-wr2q-7pgp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-24046 Advisory: Backstage has a Possible Symlink Path Traversal in Scaffolder Actions IDs: CVE-2026-24046, GHSA-rq6q-wr2q-7pgp Record: https://patchnext.com/advisories/cve-2026-24046 (revision 2, source checked 26 Oct 2026, 12:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @backstage/backend-defaults 0.14.1, 0.13.2, 0.12.2; @backstage/plugin-scaffolder-backend 3.1.1, 3.0.2, 2.2.2; @backstage/plugin-scaffolder-node 0.12.3, 0.11.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @backstage/backend-defaults: affected < 0.12.2; >= 0.13.0, < 0.13.2; >= 0.14.0, < 0.14.1; fixed in 0.12.2, 0.13.2, 0.14.1 - npm @backstage/plugin-scaffolder-backend: affected < 2.2.2; >= 3.0.0, < 3.0.2; >= 3.1.0, < 3.1.1; fixed in 3.0.2, 3.1.1, 2.2.2 - npm @backstage/plugin-scaffolder-node: affected < 0.11.2; >= 0.12.0, < 0.12.3; fixed in 0.11.2, 0.12.3 ## Suggested inspection (read-only) - `npm ls @backstage/backend-defaults --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls @backstage/plugin-scaffolder-backend --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls @backstage/plugin-scaffolder-node --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @backstage/backend-defaults, @backstage/plugin-scaffolder-backend, @backstage/plugin-scaffolder-node. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-rq6q-wr2q-7pgp (OSV record GHSA-rq6q-wr2q-7pgp lists affected ranges: npm @backstage/backend-defaults >=0 =0.13.0 =0.14.0 =0 =3.0.0 =3.1.0 =0 =0.12.0 <0.12.3 (fixed)) - Verified: https://github.com/advisories/GHSA-rq6q-wr2q-7pgp (GitHub-reviewed advisory GHSA-rq6q-wr2q-7pgp lists affected ranges: npm @backstage/backend-defaults >=0 =0.13.0 =0.14.0 =0 =3.0.0 =3.1.0 =0 =0.12.0 <0.12.3) Commands are suggestions: review each one before running it.
Loading voting…