Skip to content

← Actionable
Medium, CVSS 6.9amended

jsPDF Vulnerable to Stored XMP Metadata Injection (Spoofing & Integrity Violation)

CVE-2026-24043GHSA-vm32-vv63-w422

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (jspdf 4.1.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm jspdf

    Affected
    <= 4.0.0
    Fixed in
    4.1.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:L/SA:N · score source
EPSS
  • CVE-2026-24043: 0.29% estimated exploitation activity in the next 30 days; percentile 21.69 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact User control of the first argument of the addMetadata function allows users to inject arbitrary XML. If given the possibility to pass unsanitized input to the addMetadata method, a user can inject arbitrary XMP metadata into the generated PDF. If the generated PDF is signed, stored or otherwise processed after, the integrity of the PDF can no longer be guaranteed. Example attack vector: Patches The vulnerability has been fixed in jsPDF@4.1.0 Workarounds Sanitize user input before passing it to the addMetadata method: escape XML entities. For example:

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-vm32-vv63-w422

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-vm32-vv63-w422

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-24043

Advisory: jsPDF Vulnerable to Stored XMP Metadata Injection (Spoofing & Integrity Violation)
IDs: CVE-2026-24043, GHSA-vm32-vv63-w422
Record: https://patchnext.com/advisories/cve-2026-24043 (revision 3, source checked 26 Oct 2026, 12:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: jspdf 4.1.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm jspdf: affected <= 4.0.0; fixed in 4.1.0

## Suggested inspection (read-only)
- `npm ls jspdf --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on jspdf.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-vm32-vv63-w422 (OSV record GHSA-vm32-vv63-w422 lists affected ranges: npm jspdf >=0 <4.1.0 (fixed))
- Verified: https://github.com/advisories/GHSA-vm32-vv63-w422 (GitHub-reviewed advisory GHSA-vm32-vv63-w422 lists affected ranges: npm jspdf >=0 <=4.0.0)

Commands are suggestions: review each one before running it.

Loading voting…