jsPDF has Shared State Race Condition in addJS Plugin
CVE-2026-24040GHSA-cjw8-79x6-5cj4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (jspdf 4.1.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm jspdf
- Affected
- <= 4.0.0
- Fixed in
- 4.1.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-cjw8-79x6-5cj4 lists affected ranges: npm jspdf >=0 <4.1.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-cjw8-79x6-5cj4 lists affected ranges: npm jspdf >=0 <=4.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-24040: 0.28% estimated exploitation activity in the next 30 days; percentile 20.29 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The addJS method in the jspdf Node.js build utilizes a shared module-scoped variable (text) to store JavaScript content. When used in a concurrent environment (e.g., a Node.js web server), this variable is shared across all requests. If multiple requests generate PDFs simultaneously, the JavaScript content intended for one user may be overwritten by a subsequent request before the document is generated. This results in Cross-User Data Leakage, where the PDF generated for User A contains the JavaScript payload (and any embedded sensitive data) intended for User B. Typically, this only affects server-side environments, although the same race conditions might occur if jsPDF runs client-side. Patches The vulnerability has been fixed in jspdf@4.0.1. The fix moves the shared variable into the function scope, ensuring isolation between instances. Workarounds Avoid using the addJS method in concurrent server-side environments. If usage is required, ensure requests are processed…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-cjw8-79x6-5cj4
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-cjw8-79x6-5cj4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-24040 Advisory: jsPDF has Shared State Race Condition in addJS Plugin IDs: CVE-2026-24040, GHSA-cjw8-79x6-5cj4 Record: https://patchnext.com/advisories/cve-2026-24040 (revision 3, source checked 26 Oct 2026, 12:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: jspdf 4.1.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm jspdf: affected <= 4.0.0; fixed in 4.1.0 ## Suggested inspection (read-only) - `npm ls jspdf --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on jspdf. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-cjw8-79x6-5cj4 (OSV record GHSA-cjw8-79x6-5cj4 lists affected ranges: npm jspdf >=0 <4.1.0 (fixed)) - Verified: https://github.com/advisories/GHSA-cjw8-79x6-5cj4 (GitHub-reviewed advisory GHSA-cjw8-79x6-5cj4 lists affected ranges: npm jspdf >=0 <=4.0.0) Commands are suggestions: review each one before running it.
Loading voting…