Apache IoTDB has an Insecure Default Configuration Vulnerability
CVE-2026-24015GHSA-74cf-pgh9-m5q2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.iotdb:iotdb-core 2.0.7, 1.3.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.iotdb:iotdb-core
- Affected
- >= 1.0.0, < 1.3.7>= 2.0.0, < 2.0.7
- Fixed in
- 1.3.7, 2.0.7
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-74cf-pgh9-m5q2 lists affected ranges: Maven org.apache.iotdb:iotdb-core >=1.0.0 =2.0.0 <2.0.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-24015: 0.59% estimated exploitation activity in the next 30 days; percentile 48.45 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A vulnerability in Apache IoTDB. This issue affects Apache IoTDB: from 1.0.0 before 1.3.7, from 2.0.0 before 2.0.7. Users are recommended to upgrade to version 1.3.7 or 2.0.7, which fixes the issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-74cf-pgh9-m5q2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-24015 Advisory: Apache IoTDB has an Insecure Default Configuration Vulnerability IDs: CVE-2026-24015, GHSA-74cf-pgh9-m5q2 Record: https://patchnext.com/advisories/cve-2026-24015 (revision 1, source checked 26 Oct 2026, 16:44 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.iotdb:iotdb-core 2.0.7, 1.3.7. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.iotdb:iotdb-core: affected >= 1.0.0, < 1.3.7; >= 2.0.0, < 2.0.7; fixed in 1.3.7, 2.0.7 ## Suggested inspection (read-only) - Maven org.apache.iotdb:iotdb-core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.iotdb:iotdb-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-74cf-pgh9-m5q2 (GitHub-reviewed advisory GHSA-74cf-pgh9-m5q2 lists affected ranges: Maven org.apache.iotdb:iotdb-core >=1.0.0 =2.0.0 <2.0.7) Commands are suggestions: review each one before running it.
Loading voting…