Skip to content

← Actionable
Unrated

OpenKruise PodProbeMarker is Vulnerable to SSRF via Unrestricted Host Field

CVE-2026-24005GHSA-9fj4-3849-rv9g

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/openkruise/kruise 1.8.3, 1.7.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2026-24005: 0.33% estimated exploitation activity in the next 30 days; percentile 26.41 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary PodProbeMarker allows defining custom probes with TCPSocket or HTTPGet handlers. The webhook validation does not restrict the Host field in these probe configurations. Since kruise-daemon runs with hostNetwork=true, it executes probes from the node network namespace. An attacker with PodProbeMarker creation permission can specify arbitrary Host values (127.0.0.1, 169.254.169.254, internal IPs) to trigger SSRF from the node, perform port scanning, and receive response feedback through NodePodProbe status messages. Kubernetes Version - Kubernetes: v1.30.0 (kind cluster) - Distribution: kind Component Version - OpenKruise: v1.8.0 - kruise-daemon: DaemonSet with hostNetwork=true - Affected CRDs: PodProbeMarker, NodePodProbe Steps To Reproduce Environment Setup 1. Install OpenKruise v1.8.0 in kind cluster: 2. Verify kruise-daemon runs with hostNetwork: Output: 3. Create test namespace and RBAC: 4. Deploy victim workload: Exploitation Steps 5. Verify node-local port accessibility…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-9fj4-3849-rv9g

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-24005

Advisory: OpenKruise PodProbeMarker is Vulnerable to SSRF via Unrestricted Host Field
IDs: CVE-2026-24005, GHSA-9fj4-3849-rv9g
Record: https://patchnext.com/advisories/cve-2026-24005 (revision 1, source checked 26 Oct 2026, 15:14 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/openkruise/kruise 1.8.3, 1.7.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/openkruise/kruise: affected >= 1.8.0, < 1.8.3; < 1.7.5; fixed in 1.7.5, 1.8.3

## Suggested inspection (read-only)
- Go github.com/openkruise/kruise: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/openkruise/kruise.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-9fj4-3849-rv9g (GitHub-reviewed advisory GHSA-9fj4-3849-rv9g lists affected ranges: Go github.com/openkruise/kruise >=1.8.0 =0 <1.7.5)

Commands are suggestions: review each one before running it.

Loading voting…