Skip to content

← Actionable
Low, CVSS 3.7amended

FastAPI Api Key has a timing side-channel in verify_key that allows statistical key validity detection

CVE-2026-23996GHSA-95c6-p277-p87g

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (fastapi-api-key 1.1.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2026-23996: 0.29% estimated exploitation activity in the next 30 days; percentile 21.79 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Timing side-channel vulnerability in verifykey(). The method applied a random delay only on verification failures, allowing an attacker to statistically distinguish valid from invalid API keys by measuring response latencies. With enough repeated requests, an adversary could infer whether a keyid corresponds to a valid key, potentially accelerating brute-force or enumeration attacks. Affected: all users relying on verifykey() for API key authentication prior to the fix. Patches Yes. Users should upgrade to version 1.1.0 (or the version containing this fix). The patch applies a uniform random delay (mindelay to maxdelay) to all responses regardless of outcome, eliminating the timing correlation. Workarounds - Add an application-level fixed delay or random jitter to all authentication responses (success and failure) before the fix is applied. - Use rate limiting to reduce the feasibility of statistical timing attacks. References - CWE-208: Observable Timing Discrepancy - Commit:…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-95c6-p277-p87g

  2. Revision 1 · created ·

    Published from osv record GHSA-95c6-p277-p87g

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-23996

Advisory: FastAPI Api Key has a timing side-channel in verify_key that allows statistical key validity detection
IDs: CVE-2026-23996, GHSA-95c6-p277-p87g
Record: https://patchnext.com/advisories/cve-2026-23996 (revision 2, source checked 26 Oct 2026, 13:36 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: fastapi-api-key 1.1.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI fastapi-api-key: affected < 1.1.0; fixed in 1.1.0

## Suggested inspection (read-only)
- `python -m pip show fastapi-api-key`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on fastapi-api-key.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-95c6-p277-p87g (OSV record GHSA-95c6-p277-p87g lists affected ranges: PyPI fastapi-api-key >=0 <1.1.0 (fixed))
- Verified: https://github.com/advisories/GHSA-95c6-p277-p87g (GitHub-reviewed advisory GHSA-95c6-p277-p87g lists affected ranges: PyPI fastapi-api-key >=0 <1.1.0)

Commands are suggestions: review each one before running it.

Loading voting…