Skip to content

← Actionable
High, CVSS 7.1amended

Apache Superset Improper Authorization allows low-privileged users to bypass access controls

CVE-2026-23982GHSA-3m2g-v7jf-7fxc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (apache-superset 6.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-23982: 0.51% estimated exploitation activity in the next 30 days; percentile 43.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

An Improper Authorization vulnerability exists in Apache Superset that allows a low-privileged user to bypass data access controls. When creating a dataset, Superset enforces permission checks to prevent users from querying unauthorized data. However, an authenticated attacker with permissions to write datasets and read charts can bypass these checks by overwriting the SQL query of an existing dataset. This issue affects Apache Superset: before 6.0.0. Users are recommended to upgrade to version 6.0.0, which fixes the issue.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-3m2g-v7jf-7fxc

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-3m2g-v7jf-7fxc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-23982

Advisory: Apache Superset Improper Authorization allows low-privileged users to bypass access controls
IDs: CVE-2026-23982, GHSA-3m2g-v7jf-7fxc
Record: https://patchnext.com/advisories/cve-2026-23982 (revision 3, source checked 26 Oct 2026, 13:36 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: apache-superset 6.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI apache-superset: affected < 6.0.0; fixed in 6.0.0

## Suggested inspection (read-only)
- `python -m pip show apache-superset`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on apache-superset.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-3m2g-v7jf-7fxc (OSV record GHSA-3m2g-v7jf-7fxc lists affected ranges: PyPI apache-superset >=0 <6.0.0 (fixed))
- Verified: https://github.com/advisories/GHSA-3m2g-v7jf-7fxc (GitHub-reviewed advisory GHSA-3m2g-v7jf-7fxc lists affected ranges: PyPI apache-superset >=0 <6.0.0)

Commands are suggestions: review each one before running it.

Loading voting…