sm-crypto Affected by Signature Forgery in SM2-DSA
CVE-2026-23965GHSA-hpwg-xg7m-3p6m
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (sm-crypto 0.4.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm sm-crypto
- Affected
- < 0.4.0
- Fixed in
- 0.4.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-hpwg-xg7m-3p6m lists affected ranges: npm sm-crypto >=0 <0.4.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hpwg-xg7m-3p6m lists affected ranges: npm sm-crypto >=0 <0.4.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2026-23965: 0.21% estimated exploitation activity in the next 30 days; percentile 11.99 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A signature forgery vulnerability exists in the SM2 signature verification logic of sm-crypto. Under default configurations, an attacker can forge valid signatures for arbitrary public keys. If the message space contains sufficient redundancy, the attacker can fix the prefix of the message associated with the forged signature to satisfy specific formatting requirements. Credit This vulnerability was discovered by: - XlabAI Team of Tencent Xuanwu Lab - Atuin Automated Vulnerability Discovery Engine
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-hpwg-xg7m-3p6m
- Revision 1 · created ·
Published from osv record GHSA-hpwg-xg7m-3p6m
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-23965 Advisory: sm-crypto Affected by Signature Forgery in SM2-DSA IDs: CVE-2026-23965, GHSA-hpwg-xg7m-3p6m Record: https://patchnext.com/advisories/cve-2026-23965 (revision 2, source checked 26 Oct 2026, 12:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: sm-crypto 0.4.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm sm-crypto: affected < 0.4.0; fixed in 0.4.0 ## Suggested inspection (read-only) - `npm ls sm-crypto --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on sm-crypto. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-hpwg-xg7m-3p6m (OSV record GHSA-hpwg-xg7m-3p6m lists affected ranges: npm sm-crypto >=0 <0.4.0 (fixed)) - Verified: https://github.com/advisories/GHSA-hpwg-xg7m-3p6m (GitHub-reviewed advisory GHSA-hpwg-xg7m-3p6m lists affected ranges: npm sm-crypto >=0 <0.4.0) Commands are suggestions: review each one before running it.
Loading voting…