Skip to content

← Actionable
Critical, CVSS 9.3amended

Orval has a code injection via unsanitized x-enum-descriptions in enum generation

CVE-2026-23947GHSA-h526-wf6g-67jv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@orval/core 8.0.2, 7.19.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm @orval/core

    Affected
    >= 8.0.0-rc.0, < 8.0.2< 7.19.0
    Fixed in
    8.0.2, 7.19.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-23947: 0.84% estimated exploitation activity in the next 30 days; percentile 57.89 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Arbitrary code execution in environments consuming generated clients This issue is similar in nature to the recently-patched MCP vulnerability (CVE-2026-22785), but affects a different code path in @orval/core that was not addressed by that fix. The vulnerability allows untrusted OpenAPI specifications to inject arbitrary TypeScript/JavaScript code into generated clients via the x-enumDescriptions field, which is embedded without proper escaping in getEnumImplementation(). I have confirmed that the injection occurs during const enum generation and results in executable code within the generated schema files. Patches Upgrade to Orval 8.0.2 References An example OpenAPI showing the issue:

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-h526-wf6g-67jv

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-h526-wf6g-67jv

  4. Revision 1 · created ·

    Published from ghsa record GHSA-h526-wf6g-67jv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-23947

Advisory: Orval has a code injection via unsanitized x-enum-descriptions in enum generation
IDs: CVE-2026-23947, GHSA-h526-wf6g-67jv
Record: https://patchnext.com/advisories/cve-2026-23947 (revision 4, source checked 26 Oct 2026, 12:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @orval/core 8.0.2, 7.19.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @orval/core: affected >= 8.0.0-rc.0, < 8.0.2; < 7.19.0; fixed in 8.0.2, 7.19.0

## Suggested inspection (read-only)
- `npm ls @orval/core --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @orval/core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-h526-wf6g-67jv (GitHub-reviewed advisory GHSA-h526-wf6g-67jv lists affected ranges: npm @orval/core >=8.0.0-rc.0 =0 <7.19.0)
- Verified: https://osv.dev/vulnerability/GHSA-h526-wf6g-67jv (OSV record GHSA-h526-wf6g-67jv lists affected ranges: npm @orval/core >=8.0.0-rc.0 =0 <7.19.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…