Skip to content

← Actionable
Medium, CVSS 6.8amended

Tendenci Affected by Authenticated Remote Code Execution via Pickle Deserialization

CVE-2026-23946GHSA-339m-4qw5-j2g3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (tendenci 15.3.12), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI tendenci

    Affected
    < 15.3.12
    Fixed in
    15.3.12

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.8 · CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-23946: 0.84% estimated exploitation activity in the next 30 days; percentile 57.82 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A critical deserialization vulnerability exists in Tendenci Helpdesk module (NOTE, by default, Helpdesk is NOT enabled), affecting the version 15.3.11 and earlier. This vulnerability allows remote code execution (RCE) by an authenticated user with staff security level due to using Python's pickle module on the helpdesk /reports/. The damage is contained to the user that your Tendenci application runs. Key Finding: The original CVE-2020-14942 was incompletely patched. While ticketlist() was fixed to use safe JSON deserialization, the runreport() function still uses unsafe pickle.loads(). Permission Scoping: The impact is limited to the permissions of the user running the application, typically www-data, which generally lacks write (except for upload directories) and execute permissions. Vulnerability Details Affected Version - Version: Tendenci 15.3.11 and earlier (all versions since incomplete CVE-2020-14942 patch) - Component: tendenci/apps/helpdesk/views/staff.py Related CVE -…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-339m-4qw5-j2g3

  2. Revision 1 · created ·

    Published from osv record GHSA-339m-4qw5-j2g3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-23946

Advisory: Tendenci Affected by Authenticated Remote Code Execution via Pickle Deserialization
IDs: CVE-2026-23946, GHSA-339m-4qw5-j2g3
Record: https://patchnext.com/advisories/cve-2026-23946 (revision 2, source checked 26 Oct 2026, 13:36 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: tendenci 15.3.12. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI tendenci: affected < 15.3.12; fixed in 15.3.12

## Suggested inspection (read-only)
- `python -m pip show tendenci`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on tendenci.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-339m-4qw5-j2g3 (OSV record GHSA-339m-4qw5-j2g3 lists affected ranges: PyPI tendenci >=0 <15.3.12 (fixed))
- Verified: https://github.com/advisories/GHSA-339m-4qw5-j2g3 (GitHub-reviewed advisory GHSA-339m-4qw5-j2g3 lists affected ranges: PyPI tendenci >=0 <15.3.12)

Commands are suggestions: review each one before running it.

Loading voting…