qs's arrayLimit bypass in comma parsing allows denial of service
CVE-2026-2391GHSA-w7fw-mjwx-w883
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (qs 6.14.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm qs
- Affected
- >= 6.7.0, <= 6.14.1
- Fixed in
- 6.14.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-w7fw-mjwx-w883 lists affected ranges: npm qs >=6.7.0 <6.14.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w7fw-mjwx-w883 lists affected ranges: npm qs >=6.7.0 <=6.14.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 3.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L
- EPSS
- CVE-2026-2391: 0.54% estimated exploitation activity in the next 30 days; percentile 45.62 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The arrayLimit option in qs does not enforce limits for comma-separated values when comma: true is enabled, allowing attackers to cause denial-of-service via memory exhaustion. This is a bypass of the array limit enforcement, similar to the bracket notation bypass addressed in GHSA-6rw7-vpxm-498p (CVE-2025-15284). Details When the comma option is set to true (not the default, but configurable in applications), qs allows parsing comma-separated strings as arrays (e.g., ?param=a,b,c becomes ['a', 'b', 'c']). However, the limit check for arrayLimit (default: 20) and the optional throwOnLimitExceeded occur after the comma-handling logic in parseArrayValue, enabling a bypass. This permits creation of arbitrarily large arrays from a single parameter, leading to excessive memory allocation. Vulnerable code (lib/parse.js: lines ~40-50): The split(',') returns the array immediately, skipping the subsequent limit check. Downstream merging via utils.combine does not prevent allocation,…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-w7fw-mjwx-w883
- Revision 1 · created ·
Published from osv record GHSA-w7fw-mjwx-w883
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-2391 Advisory: qs's arrayLimit bypass in comma parsing allows denial of service IDs: CVE-2026-2391, GHSA-w7fw-mjwx-w883 Record: https://patchnext.com/advisories/cve-2026-2391 (revision 2, source checked 26 Oct 2026, 12:42 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 3.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: qs 6.14.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm qs: affected >= 6.7.0, <= 6.14.1; fixed in 6.14.2 ## Suggested inspection (read-only) - `npm ls qs --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on qs. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-w7fw-mjwx-w883 (OSV record GHSA-w7fw-mjwx-w883 lists affected ranges: npm qs >=6.7.0 <6.14.2 (fixed)) - Verified: https://github.com/advisories/GHSA-w7fw-mjwx-w883 (GitHub-reviewed advisory GHSA-w7fw-mjwx-w883 lists affected ranges: npm qs >=6.7.0 <=6.14.1) Commands are suggestions: review each one before running it.
Loading voting…