Skip to content

← Actionable
High, CVSS 7.5amended

Apollo Serve vulnerable to Denial of Service with startStandaloneServer

CVE-2026-23897GHSA-mp6q-xf9x-fwf7

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm apollo-server

    Affected
    >= 2.0.0, <= 3.13.0
    Fixed in
    no fixed version recorded
  • npm @apollo/server

    Affected
    >= 4.2.0, < 4.13.0>= 5.0.0, < 5.4.0
    Fixed in
    4.13.0, 5.4.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-23897: 0.69% estimated exploitation activity in the next 30 days; percentile 52.80 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The default configuration of startStandaloneServer from @apollo/server/standalone is vulnerable to Denial of Service (DoS) attacks through specially crafted request bodies with exotic character set encodings. This issue does not affect users that use @apollo/server as a dependency for integration packages, like @as integrations/express5 or @as-integrations/next, only direct usage of startStandaloneServer. Who is impacted Users directly using startStandaloneServer from @apollo/server/standalone. This issue affects Apollo Server from v5.0.0 through v5.3.x. It also affects all releases of the end-of-life major versions v4, v3, and v2. Although Apollo Server v4 is EOL and Apollo no longer commits to providing support or updates for it, a fix for it was released in v4.13.0. Apollo Server v3 and v2 are no longer updated, as they have been EOL since 2024 and 2023 respectively. Patches Patches for this issue are released as @apollo/server versions 5.4.0 and 4.13.0. In accordance with…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-mp6q-xf9x-fwf7

  2. Revision 1 · created ·

    Published from osv record GHSA-mp6q-xf9x-fwf7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-23897

Advisory: Apollo Serve vulnerable to Denial of Service with `startStandaloneServer`
IDs: CVE-2026-23897, GHSA-mp6q-xf9x-fwf7
Record: https://patchnext.com/advisories/cve-2026-23897 (revision 2, source checked 26 Oct 2026, 12:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: @apollo/server 5.4.0, 4.13.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm apollo-server: affected >= 2.0.0, <= 3.13.0
- npm @apollo/server: affected >= 4.2.0, < 4.13.0; >= 5.0.0, < 5.4.0; fixed in 4.13.0, 5.4.0

## Suggested inspection (read-only)
- `npm ls apollo-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @apollo/server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on apollo-server, @apollo/server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-mp6q-xf9x-fwf7 (OSV record GHSA-mp6q-xf9x-fwf7 lists affected ranges: npm apollo-server >=2.0.0 =4.2.0 =5.0.0 <5.4.0 (fixed))
- Verified: https://github.com/advisories/GHSA-mp6q-xf9x-fwf7 (GitHub-reviewed advisory GHSA-mp6q-xf9x-fwf7 lists affected ranges: npm apollo-server >=2.0.0 =4.2.0 =5.0.0 <5.4.0)

Commands are suggestions: review each one before running it.

Loading voting…