Skip to content

← Actionable
Medium, CVSS 6.0amended

OctoPrint has Timing Side-Channel Vulnerability in API Key Authentication

CVE-2026-23892GHSA-xg4x-w2j3-57h6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (octoprint 1.11.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.0 · CVSS:4.0/AV:A/AC:H/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-23892: 0.43% estimated exploitation activity in the next 30 days; percentile 37.64 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact OctoPrint versions up to and including 1.11.5 are affected by a (theoretical) timing attack vulnerability that allows API key extraction over the network. Due to using character based comparison that short-circuits on the first mismatched character during API key validation, rather than a cryptographical method with static runtime regardless of the point of mismatch, an attacker with network based access to an affected OctoPrint could extract API keys valid on the instance by measuring the response times of the denied access responses and guess an API key character by character. Patches The vulnerability will be patched in version 1.11.6. Workaround The likelihood of this attack actually working is highly dependent on the network's latency, noise and similar parameters. An actual proof of concept was not achieved so far. Still, as always administrators are advised to not expose their OctoPrint instance on hostile networks, especially not on the public Internet! Credits This…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-xg4x-w2j3-57h6

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-xg4x-w2j3-57h6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-23892

Advisory: OctoPrint has Timing Side-Channel Vulnerability in API Key Authentication
IDs: CVE-2026-23892, GHSA-xg4x-w2j3-57h6
Record: https://patchnext.com/advisories/cve-2026-23892 (revision 3, source checked 26 Oct 2026, 13:36 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: octoprint 1.11.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI octoprint: affected < 1.11.6; fixed in 1.11.6

## Suggested inspection (read-only)
- `python -m pip show octoprint`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on octoprint.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-xg4x-w2j3-57h6 (OSV record GHSA-xg4x-w2j3-57h6 lists affected ranges: PyPI octoprint >=0 <1.11.6 (fixed))
- Verified: https://github.com/advisories/GHSA-xg4x-w2j3-57h6 (GitHub-reviewed advisory GHSA-xg4x-w2j3-57h6 lists affected ranges: PyPI octoprint >=0 <1.11.6)

Commands are suggestions: review each one before running it.

Loading voting…