Skip to content

← Actionable
Medium, CVSS 6.5amended

pnpm: Binary ZIP extraction allows arbitrary file write via path traversal (Zip Slip)

CVE-2026-23888GHSA-6pfh-p556-v868

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pnpm 10.28.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm pnpm

    Affected
    < 10.28.1
    Fixed in
    10.28.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N
EPSS
  • CVE-2026-23888: 0.45% estimated exploitation activity in the next 30 days; percentile 39.17 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A path traversal vulnerability in pnpm's binary fetcher allows malicious packages to write files outside the intended extraction directory. The vulnerability has two attack vectors: (1) Malicious ZIP entries containing ../ or absolute paths that escape the extraction root via AdmZip's extractAllTo, and (2) The BinaryResolution.prefix field is concatenated into the extraction path without validation, allowing a crafted prefix like ../../evil to redirect extracted files outside targetDir. Details The vulnerability exists in the binary fetching and extraction logic: 1. Unvalidated ZIP Entry Extraction (fetching/binary-fetcher/src/index.ts) AdmZip's extractAllTo does not validate entry paths for path traversal: A ZIP entry with path ../../../.npmrc will be written outside nodeDir. 2. Unvalidated Prefix in BinaryResolution (resolving/resolver-base/src/index.ts) The basename variable comes from BinaryResolution.prefix and is used directly in path construction: PoC Attack Vector 1:…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-6pfh-p556-v868

  2. Revision 1 · created ·

    Published from osv record GHSA-6pfh-p556-v868

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-23888

Advisory: pnpm: Binary ZIP extraction allows arbitrary file write via path traversal (Zip Slip)
IDs: CVE-2026-23888, GHSA-6pfh-p556-v868
Record: https://patchnext.com/advisories/cve-2026-23888 (revision 2, source checked 26 Oct 2026, 12:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pnpm 10.28.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm pnpm: affected < 10.28.1; fixed in 10.28.1

## Suggested inspection (read-only)
- `npm ls pnpm --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pnpm.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-6pfh-p556-v868 (OSV record GHSA-6pfh-p556-v868 lists affected ranges: npm pnpm >=0 <10.28.1 (fixed))
- Verified: https://github.com/advisories/GHSA-6pfh-p556-v868 (GitHub-reviewed advisory GHSA-6pfh-p556-v868 lists affected ranges: npm pnpm >=0 <10.28.1)

Commands are suggestions: review each one before running it.

Loading voting…