AlchemyCMS: Authenticated Remote Code Execution (RCE) via eval injection in ResourcesHelper
CVE-2026-23885GHSA-2762-657x-v979
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (alchemy_cms 8.0.3, 7.4.12), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems alchemy_cms
- Affected
- < 7.4.12>= 8.0.0.a, < 8.0.3
- Fixed in
- 8.0.3, 7.4.12
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2762-657x-v979 lists affected ranges: RubyGems alchemy_cms >=0 =8.0.0.a <8.0.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.4 · CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-23885: 0.47% estimated exploitation activity in the next 30 days; percentile 40.89 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A vulnerability was discovered during a manual security audit of the AlchemyCMS source code. The application uses the Ruby eval() function to dynamically execute a string provided by the resourcehandler.enginename attribute in Alchemy::ResourcesHelper#resourceurlproxy. Details The vulnerability exists in app/helpers/alchemy/resourceshelper.rb at line 28. The code explicitly bypasses security linting with
rubocop:disable Security/Eval, indicating that the use of a dangerous function was known but not properly mitigated. Since enginename is sourced from module definitions that can be influenced by administrative configurations, it allows an authenticated attacker to escape the Ruby sandbox and execute arbitrary system commands on the host OS. But, for this attack to be possible local file access to the alchemy project or the source on a remote server is necessary in order to manipulate the module config file, though. PoC (Proof of Concept) The following standalone Ruby script…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-2762-657x-v979
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-23885 Advisory: AlchemyCMS: Authenticated Remote Code Execution (RCE) via eval injection in ResourcesHelper IDs: CVE-2026-23885, GHSA-2762-657x-v979 Record: https://patchnext.com/advisories/cve-2026-23885 (revision 1, source checked 26 Oct 2026, 15:51 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: alchemy_cms 8.0.3, 7.4.12. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems alchemy_cms: affected < 7.4.12; >= 8.0.0.a, < 8.0.3; fixed in 8.0.3, 7.4.12 ## Suggested inspection (read-only) - RubyGems alchemy_cms: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on alchemy_cms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-2762-657x-v979 (GitHub-reviewed advisory GHSA-2762-657x-v979 lists affected ranges: RubyGems alchemy_cms >=0 =8.0.0.a <8.0.3) Commands are suggestions: review each one before running it.
Loading voting…