Skip to content

← Actionable
High, CVSS 7.7

Kyverno Denial of Service via Context Variable Amplification in Policy Engine

CVE-2026-23881GHSA-r2rj-wwm5-x6mq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/kyverno/kyverno 1.16.3, 1.15.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.7 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:N/A:H
EPSS
  • CVE-2026-23881: 0.62% estimated exploitation activity in the next 30 days; percentile 49.67 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Unbounded memory consumption in Kyverno's policy engine allows users with policy creation privileges to cause Denial of Serviceby crafting policies that exponentially amplify string data through context variables. Details For example, the random() JMESPath function in pkg/engine/jmespath/functions.go generates random strings. Combined with the join() function, an attacker can create exponential string amplification through context variable chaining: The PoC attack uses exponential doubling: - l0 = random('[a-zA-Z0-9]{1000}') → 1KB - l1 = join('', [l0, l0]) → 2KB - l2 = join('', [l1, l1]) → 4KB - ... continues to l18 → 256MB The context evaluation has no cumulative size limit, allowing unbounded memory allocation. PoC Tested on Kyverno v1.16.1 on k8s v1.34.0 (kind). 1. Create namespace: 2. Observe pod statuses from kyverno namespace on another terminal: 2. Apply malicious policy: As soon as you apply this, you'll see the reports controller gets OOM killed and the container…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-r2rj-wwm5-x6mq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-23881

Advisory: Kyverno Denial of Service via Context Variable Amplification in Policy Engine
IDs: CVE-2026-23881, GHSA-r2rj-wwm5-x6mq
Record: https://patchnext.com/advisories/cve-2026-23881 (revision 1, source checked 26 Oct 2026, 15:14 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/kyverno/kyverno 1.16.3, 1.15.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/kyverno/kyverno: affected < 1.15.3; >= 1.16.0-rc.1, < 1.16.3; fixed in 1.15.3, 1.16.3

## Suggested inspection (read-only)
- Go github.com/kyverno/kyverno: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/kyverno/kyverno.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-r2rj-wwm5-x6mq (GitHub-reviewed advisory GHSA-r2rj-wwm5-x6mq lists affected ranges: Go github.com/kyverno/kyverno >=0 =1.16.0-rc.1 <1.16.3)

Commands are suggestions: review each one before running it.

Loading voting…