Skip to content

← Actionable
High, CVSS 8.0amended

py7zr: Arbitrary File Write Vulnerability

CVE-2026-23879GHSA-q6rc-2cgv-63h7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (py7zr 1.1.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI py7zr

    Affected
    <= 1.1.2
    Fixed in
    1.1.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.0 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-23879: 0.50% estimated exploitation activity in the next 30 days; percentile 42.71 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary There exists an arbitrary file write vulnerability in py7zr (1.1.0, latest), which allows symbolic links to be recreated outside the destination directory via crafted malicious symbolic link chains. When using extractall to extract an archive, the library restores these symbolic links, linking them to arbitrary directories on the host file system. Subsequent extraction of regular files through these symbolic links can result in arbitrary file writes. This vulnerability may lead to remote code execution, privilege escalation, data corruption, or denial of service. Details The root cause of this vulnerability is that py7zr fails to properly restrict the targets of symbolic links within an archive. During extraction, the program only checks the link arcname within the destination directory, but ignores the combined symlink path resolution. Attackers can exploit this vulnerability by constructing malicious archives, thereby bypassing the directory boundary restrictions…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-q6rc-2cgv-63h7

  2. Revision 1 · created ·

    Published from osv record GHSA-q6rc-2cgv-63h7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-23879

Advisory: py7zr: Arbitrary File Write Vulnerability
IDs: CVE-2026-23879, GHSA-q6rc-2cgv-63h7
Record: https://patchnext.com/advisories/cve-2026-23879 (revision 2, source checked 26 Oct 2026, 13:49 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: py7zr 1.1.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI py7zr: affected <= 1.1.2; fixed in 1.1.3

## Suggested inspection (read-only)
- `python -m pip show py7zr`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on py7zr.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-q6rc-2cgv-63h7 (OSV record GHSA-q6rc-2cgv-63h7 lists affected ranges: PyPI py7zr >=0 <1.1.3 (fixed))
- Verified: https://github.com/advisories/GHSA-q6rc-2cgv-63h7 (GitHub-reviewed advisory GHSA-q6rc-2cgv-63h7 lists affected ranges: PyPI py7zr >=0 <=1.1.2)

Commands are suggestions: review each one before running it.

Loading voting…